Problem on IDEA6.0+Tomcat5.0 debugging

Answered

Hello everyone,

I have problem on IDEA6.0+Tomcat5.0 debugging:
If I debug with socket, IDEA tell me "Failed to establish connection to the target VM, address: '127.0.0.1:1125', transport: 'socket'",
and if I debug with shared memory, IDEA tell me "Failed to establish connection to the target VM, address: 'javadebug', transport: 'shared memory'".

I had use the workaround
1) Select Socket transport
2) fill suitable address value (e.g. "javadebug") to "Port" field
3) Select Shared memory transport
but the problem is still on.

I had uninstalled IDEA(deleted the config and cache),reinstall it,but the problem is still on, and sometimes the debug window came to disabled(grey) when I clicked the debug button.But in the task manager, I had a java process.

My OS is windows xp + sp2.

How can I solve this problem? Thanks in advance!

8 comments

Please choose the "socket transport" and clear the "debug port" value. Upon connect IDEA will choose an available port for debugger
connection.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Eugene Zhuravlev:
Thank you for your reply.
I have tried your advice, but the problem still exist. Can you check it?

0

I have tried your advice, but the problem still exist. Can you check it?


ell, works ok for me. Please send me your ipr, iml and iws filles + the name of the run configuration you are using to start Tomcat


0

OK. The tomcatfromscratch.rar in the attachment is my project, and the tomcatstart.jpg is my Tomcat debug startup config page. I just click the "debug" button to start my debug.

PS:My OS is windows xp + sp2 Chinese Simplified.



Attachment(s):
tomcatstart.jpg
tomcatfromscratch.rar
0

The problem has been solved!
Just because I set JAVA_OPTS in my catalina.bat file already.
Thanks!

0

Ok, thanks for informing!

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Wisen" <no_mail@jetbrains.com> wrote in message news:31227780.1160472384799.JavaMail.itn@is.intellij.net...

The problem has been solved!
Just because I set JAVA_OPTS in my catalina.bat file already.
Thanks!



0

I also meet this problem about " IDEA connected to the target vm address:'javadebug',transport:'shared memory",But have no idea for it.

I donot know how to set the the value of JAVA_OPT in catalina.bat...

EveryOne will connect to me :pxz015@163.com(that is zero)

0

Hi, Pxz015. the solution provided here is from 2006, so it is most likely outdated. Could you please raise a ticket at https://youtrack.jetbrains.com/issues, with a problem description and idea.log attached.

0

Post is closed for comments.