mac os x compile error

Hi,

I installed 691 (over a previously installed 690) I just ran the installer choosing defaults and when I compile I get this error:

Information: 1 error
Information: 0 warnings
Information: HotSpot not at correct virtual address. Sharing disabled.
Information: Exception in thread "main" java.lang.ClassNotFoundException: -verbose
Information: at java.lang.Class.forName0(Native Method)
Information: at java.lang.Class.forName(Class.java:140)
Information: at com.intellij.rt.compiler.JavacRunner.main(JavacRunner.java:24)
Error: line (0) The compiler did not terminate normally. Exit code is 1

This does not look like the works in command line (but it might be) so I posted it as a new thread.

Also, what give gives with the file name and tab text clipping? That looks new to me.

5 comments
Comment actions Permalink

I am experiencing the same problem. You can read all the details at
http://www.intellij.net/forums/thread.jsp?forum=22&thread=22013&tstart=0&trange=15

If you find an answer please post it.

0
Comment actions Permalink

you guys are missing the classes.jar from the JDK classes list. Add it and everything should work. IDEA doesn't add this one for some reason.

0
Comment actions Permalink

i added classes.jar in my jdk config and it still did not work

0
Comment actions Permalink

i got it working. i had to copy the jar files from the classes directory into the home/lib directory, then remove the jdk and re-add it. i have no idea why adding the jars from the classes directory into the jdk as jars did not work but it does now

0
Comment actions Permalink

I solved my problem by completely uninstalling 691.

First I ran the uninstaller
Next I rm -rf ~/.Intellij*

NOTE: this could delete any customizations you've made.

Next, run the 691 installer again.

Finally, I added the new JDK by selecting:

/System/Library/Frameworks/JavaVM.framework/Versions/1.4.1/Home/

I was now able to compile.
Other issues remain like fakey menu selection and font clipping.

0

Please sign in to leave a comment.