Performance issues under windows 7

Hi,
I'm using PhpStorm for several years under Windows 7.

I was able to reconstruct this issue on three different PCs. All running Windows 7.

After a while of working everything freezes in PhpStorm. Then I have to wait few seconds and everything continues as usual.
Keyboard entries while freezing are performed after the freeze is gone.

I have this circumstance since few month. And today it is anoying me so much, I've started this post ;-)

It is not a specia action I am doing when PhpStorm freezes. Just entering things like:
pri
*freeze*
*still freezed*
*becoming angry*
print_r

It also happens in non-php files, like html or css. Doesn't matter.

I know it is probably very difficult to investigate for this bug/issue. So am I able to support you? Is there a debug option I could activate? Or something similar?

I am using the latest PhpStorm version 8.0.1 #PS-138.2001.
I've also updated java: 1.7.0_60-b19 x86
This issue already appears in PhpStorm 7.

Thanks in advance.
Armin

8 comments

Hi,

If this is still an issue, please capture jstack thread dumps during freeze and provide them: https://intellij-support.jetbrains.com/entries/23348667 .

0

Hi. Today this issue is annoying me very much!

It has something to do with autocomplete.
Here a screenshot of what I did, when PhpStorm freezes:
2015-02-27_1620.png
Usually it freezes for ~10 seconds after entering a single letter, before autocomplete shows up.
While writing this post, it happened a second time:
2015-02-27_1623.png
Currently this issue appears extremly often.

0

tune your VM and try the EAP 8.0.3 (based on common code build 139). That did wonders for me with AppCode.

0

Where project files & user profile is located -- is it all local or maybe over network / VM ?

Currently this issue appears extremly often.

Please provide thread dumps / log files as it was suggested earlier.

0

Hi,
I coded for many releases of PHPStorm on WIN-7 and never had a problem. Especially when coding Laravel apps, as they contain a large codebase to start.  How much memory does your system have, and disk space?  How much free space?  How big is your PHPStorm project?  How many projects do you normally open at a time?  What other apps do you have running?  When you run the bare minimum doesm thisn happen.  In very, very early days of IntelliJ this would happen.  But that was a long time ago.  Do you use any plugins?  How long does it take PHPStorm to index your project?  Have you checked for adware, malware?  Do have sublime? What happens when you try to edit same files with that?  Start task manager and sort process list by CPU usage see if any tasks are scanning your disk, eating io some way?

0

Strange. Today this issue did not appear at all, and I worked on the largest project I've got.

My projects are usually not so big. Full indexing takes 15-30 seconds (including external libraries).
I am always working locally (with Git and Deployment targets).

Besides PhpStorm, I have usually the following applications open:
Microsoft Outlook, Skype, Google Chrome and Keepass.

I think I'll need to investigate further, if I am the only one with this issue. Maybe settings like
Code Sniffer are the reasons for that... But I am not sure.

Thanks so far for your responses.

0

Well, at home I am not using Keepass and the same issue appears in PhpStorm.
2015-03-04_0423.png

The only applications I am currently using are:
PhpStorm, Chrome, Virtual Box (using vagrant)

The Windows 7 uptime (time since last boot) is less than 2 hours.

Before this happend again, I've invalidated the caches und restarted PhpStorm. The (re-)indexing took 45 seconds for this project.
During this time PhpStorm got 75% CPU usage.

Then, when PhpStorm hang up again, no CPU has been used at all.

Here is my full process list:
2015-03-04_0438.png
2015-03-04_0437.png



There is also another weird circumstance, I've caught on video:
http://screencast.com/t/r3DPZOML
Why does PhpStorm not know about the class, I've already used one line!! before?

0

Please sign in to leave a comment.