Ubuntu 6.06 problems with IDEA main window

Last night I did a clean install of IDEA build 4267 on a Ubuntu 6.06 box. I setup my Java path and I am using Java 5.0.05. When I run the idea.sh script it comes up and appears to work, but if I invoke any dialog such as the "Checkout from CVS Repository" dialog the main IDEA window disappears and all I see is the dialog box. After I enter the data and click the OK button I get nothing on the screen. The main IDEA window never returns. The tool/menu bar at the top of the screen is gone so I can't even shutdown the box. I have to hit reset. I tried this several times and each time I get the same problem.

If I have a console window open and I try to run idea.sh again it tells me that a copy of IDEA is already running. I can do a kill -9 pid and regain control, but if I run idea.sh again I get the same issue.

Please help. I have been running IDEA under Windows for several years, but now I want to do some development under the Linux environment.

1 comment
Comment actions Permalink

I think I am to late with my reply. But still for anybody who finds this thread like I did, my reply might be helpful.

I just found this thread (http://intellij.net/forums/thread.jspa?forumID=27&threadID=189420) I found a post by Brett Sealey (thank you) which solved all my problems:


For the reference of others who run into this problem.

On Dapper the toxic fonts are Rekha-normal and aakar-MagNet these are in the ttf-gujarati-fonts package.

To workaround this use:
sudo apt-get remove ttf-gujarati-fonts

Note: that this will harmlessly remove the meta-packages ubuntu-desktop and indic-fontsm.

This information should be added to a FAQ somewhere.

btw: the JVM failure apparently happens on the next font after the toxic ones. Hence the confusion about which font(s) was causing the failures in the earlier posts. Something to keep in mind if you need to track down other toxic fonts.

0

Please sign in to leave a comment.