Error while compiling classes using Intellij 5.1.1 + jdk 1.3.1

Hi,

I installed new version 5.1.1 of IntelliJ and now I am getting compilation error as below.. In previous version, everything was working well.

I also tried to change jdk to 1.4.. but getting same error.

Can you please help me out to resolve this problem.

Thanks,
Chetan.
Information:Compilation completed with 13 errors
Information:13 errors
Error:Bad class file format:121
Error:Bad class file format:10
Error:Bad class file format:50
Error:Bad class file format:70
Error:Bad class file format:30
Error:Bad class file format:20
Error:Bad class file format:40
Error:Bad class file format:31
Error:Bad class file format:60
Error:Bad class file format:0
Error:Bad class file format:90
Error:Bad class file format:100
Error:Bad class file format:51

10 comments
Comment actions Permalink

I just upgraded from IntelliJ 5.0 to 5.1 and now I get:

Error: Bad class file format: 31
Error: Bad class file format: 16

I have tried rebuilding, changing java versions... nothing has worked.

0
Comment actions Permalink

1) Check that your JVM settings are set to the right jvm.

2) Check that IntelliJ is running with the latest VM on your pc or the one it (IJ) came with.

3) Try wiping your output folder where class files go (Idea will create a whole new one). Perhaps they have changed something in the format.

0
Comment actions Permalink

The java compiler version in my project is 1.5.0_07 b3.
The bundled IntelliJ java version is 1.5.0_07 b3.

0
Comment actions Permalink

I have followed all your steps and I am unable to fix this either. If I hit compile twice it goes away, but as soon as I make a change and recompile it is back....

I even gave 5.1.2 a try.

0
Comment actions Permalink

I upgraded to Intellij 5.1.2 and now I am able to compile all class well.

0
Comment actions Permalink

I'm yet another victim. I have tried

-updating to intellij 5.1.2
-reconfiguring the jdk options of my project
-reinstalling jdk1.5 (my sources are only compatible to jdk1.5)
-deleting all classes (the worst case, i had to re-make my project dozens of times)
-deleting the cache files of intellij in my home dir

NONE OF THESE WORKED!

0
Comment actions Permalink

Check file types in intellij settings - I had a blank line under Java class files. When removed that then everything worked just fine.

0
Comment actions Permalink

Thanks A LOT!!! You did it; I couldn't resolved this issue for a long time, thanks!

0
Comment actions Permalink

Wow, this fix worked for me too. I'm not sure how a blank filetype showed up here, but it sure did. FWIW, I was running IntelliJ 5.1.2 and JDK 1.4.x, so I'm guessing it's more of an IDEA issue than a JDK one.

Thanks for posting it! Not sure how I'd find that on my own.

0
Comment actions Permalink

Worked for me, too! Thanks a lot!

0

Please sign in to leave a comment.