LiveEdit in PhpStorm 8.0.2 unavailable

Hey!

So, I'm working on a CodeIgniter project in PhpStorm 8.0.2 and I'm trying to enable LiveEdit.

My project is running on XAMPP.

I've got the plugin installed and active.

I've got a JavaScript Debug session running. URL is http://localhost/.

I've got the Chrome Extension installed, I see the "JetBrains IDE Support is debugging this tab" toolbar and the extension icon says "Connected to PhpStorm 8.0.2".

But Live Edit isn't an option in the View menu. Am I missing a step?

6 comments
Comment actions Permalink

It shouldn't be there. View/Live Edit menu has been removed. Please see http://blog.jetbrains.com/webstorm/2014/08/live-edit-updates-in-webstorm-9/.

0
Comment actions Permalink

Thanks. When I update a PHP file the page refreshes correctly, but there's no refresh when I update a CSS or JS file.

0
Comment actions Permalink

Please make sure that 'Update' in Preferences/Debugger/Live Edit is  set to 'Auto in (ms)' and 'Restart if hotswap fails' is enabled.


Changes in HTML code are updated in the browser automatically  regardless of the selected Update mode; but this is not the case for js  and css - in Manual mode, you need to click the Update Application  button on the debugger tool window or in the main Run menu, or press  cmd+F10 to get page refreshed.  See http://blog.jetbrains.com/webstorm/2014/08/live-edit-updates-in-webstorm-9/
0
Comment actions Permalink

Yeah, it's set to auto 300ms and Restart if hotswap fails. But CSS changes still aren't working. Even if I select "Update Application (Live Edit)" manually.

0
Comment actions Permalink

Please attach a screencast that shows up your issue


0
Comment actions Permalink

it is strange people ask about phpstorm 8.0.2 and answer give a link to webstorm  9  !!!
why ?

I still find cubersome the way phpstorm let us configure ? the default internal http server port.

regard's

0

Please sign in to leave a comment.