PHPStorme crashes while indexing

I am setting up PHPStorm on a RedHat server running Gnome.  I am having trouble keeping PHPStorm from crashing.  It appears that the issue occurs when a memory intense operation is running like when PHPStorm inexes files.  When it crashes, this is what I get on the command line.

/home/robbert/PhpStorm-139.1348/bin/phpstorm.sh: line 178:  3000 Killed                  /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.75.x86_64/jre/bin/java -Xms128m -Xmx512m -XX:MaxPermSize=250m -XX:ReservedCodeCacheSize=64m -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -Djsse.enableSNIExtension=false -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -Dawt.useSystemAAFontSettings=lcd -Djb.vmOptionsFile="/home/robbert/PhpStorm-139.1348/bin/phpstorm64.vmoptions" -XX:ErrorFile=/home/robbert/java_error_in_WEBIDE_%p.log "-Xbootclasspath/a:/home/robbert/PhpStorm-139.1348/bin/../lib/boot.jar" -Didea.paths.selector=WebIde80 -Didea.platform.prefix=PhpStorm -Didea.no.jre.check=true -Djb.restart.code=88 com.intellij.idea.Main


My guess is that there's an issue with my Java settings or maybe something with PHPStorm, but I cannot figure out what to change to make this stable. What can I do?
2 comments
Comment actions Permalink

Try to install Oracle JDK.

0
Comment actions Permalink

Thnaks for the feedback. I tried this and had the same result.

I ended up fixing the problem by increasing the swap space on my server.

0

Please sign in to leave a comment.