JBoss with Idea Issue?

Hi

I am using JBoss(3.0.0) which is BUNDLED with Tomcat(4.0.3). I am using IDEA(3.0.1). I am using WIN XP.

I read article by Robert at http://www.intellij.org/twiki/bin/view/Main/JBossIntegration

I want to INTEGRATE JBOSS with my IDE and followed above URL instructions. I first installed jbossIntegration\lib directory to my C:\IDEA\plugin and then followed above URL's instruction to create web app. My web app name is kithany and created a directory kithany.war in JBoss\server\default\deploy

I then create a NEW Project in IDEA. I enter following information:
Name: kithany
Location: C:\Documents and Settings\mkithany\IdeaProjects\kithany.ipr
Target JDK 1.3
Compiler output path C:\JBoss\server\default\deploy\kithany.war\WEB-INF\classes

Project Path C:\JBoss\server\default\deploy\kithany.war
Source Path C:\JBoss\server\default\deploy\kithany.war
Classpath Selected all files in
*C:\jdk1.3\lib\tools.jar
C:\Jboss\catalina\server\common\lib\*.jar
C:\Jboss\catalina\server\lib\*.jar*


Later when I RUN. I get a screen (which has 4 Tabs: Application, Applet, JUnit and WebApp). I click ADD a WebApp with following information:
Name:kithany
Web Application Name: kithany (C:\JBoss\server\default\deploy\kithany.war)
Application Server: JBoss 3.0.x / Jetty 4.x
Debuggee Host: localhost
Debuggee Port: 5050
Catalina Home: C:\JBoss\catalina
Path to Catalina Config: C:\JBoss\catalina\conf
Application context path: \kithany

After this, do I have to ADD a Application on my Application Tab of the Run Screen? or only WEB APPLICATION itselfIf I need an APplication then what would be the Main Class and other Program paramaters?

Later when I run my browser as http://localhost:8080/kithany - it shows *Apache Tomcat/4.0.3 - HTTP Status 404 - /kithany
The requested resource (/kithany) is not available*
Do I have to have port as 8080 or 5050?

Would really appreciate if you could give some information on above error.

THANKS.

1 comment
Comment actions Permalink

Again, JBoss with TOmcat won't work with the plugin. You don't mention what is wrong with JBoss Jetty as you wrote me in the email. It works for me here of course and I know others have used it.

0

Please sign in to leave a comment.