Web App not working with JBoss

*Hi Experts:*

I am using TOMCAT_4.0.3 (bundled with JBOSS3.0.0_) and using IntelliJ-IDEA as my IDE environment.

On one of my machine I created a WEB-APP kithany.war. It was working fine on this machine.

Later when I copied this kithany.war to other machine and put under server/default/deploy directory and then ran Jboss on which I get following error - wonder why?

-


-



WHat is wrong on this...? Any related information on above is appreciated.

THANKS!

1 comment
Comment actions Permalink

Please quit cross-posting!

"Manoj G. Kithany" <jiveadmin@jetbrains.com> wrote in message
news:1882108.1040245079744.JavaMail.jrun@is.intellij.net...

*Hi Experts:*

>

I am using TOMCAT_4.0.3 (bundled with JBOSS3.0.0_)

and using IntelliJ-IDEA as my IDE environment.
>

On one of my machine I created a WEB-APP kithany.war. It was

working fine on this machine.
>

Later when I copied this kithany.war to other machine and put under

server/default/deploy directory and then ran Jboss on which I get
following error - wonder why?
>

------------------------------------------------------

 *13:32:34,156 INFO  [EmbeddedCatalinaServiceSX] deploy,
ctxPath=/kithany,
warUrl=file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/
> 13:32:34,281 ERROR [MainDeployer] could not start deployment:
file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/
> org.jboss.deployment.DeploymentException: Error during deploy; - nested
throwable: (java.lang.NullPointerException)
> at
org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:309)*
at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)
> at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:513)
>
>
> java.lang.NullPointerException
> at
org.jboss.web.catalina.EmbeddedCatalinaServiceSX.createWebContext(EmbeddedCa
talinaServiceSX.java:321)
> at
org.jboss.web.catalina.EmbeddedCatalinaServiceSX.performDeploy(EmbeddedCatal
inaServiceSX.java:238)
> at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:300)
> at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)
> at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:513)
>
>
> *13:32:34,281 ERROR [URLDeploymentScanner] Failed to deploy:
org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL@6417805a{
url=file:/C:/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/kithany.war/,[/b
] deployedLastModified=0 }
> org.jboss.deployment.DeploymentException: Error during deploy; - nested
throwable: (java.lang.NullPointerException)
> at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:309)
> at org.jboss.deployment.MainDeployer.start(MainDeployer.java:678)]]>

------------------------------------------------------

>

WHat is wrong on this...? Any related information on above is appreciated.

>

THANKS!

>


0

Please sign in to leave a comment.