Help with Light Bulb

Not sure what you call it but that light bulb use to pop up whenever I had unused imports. It would allow me to select optimize imports. I accidently turned it off for imports and I don't know how to turn it back on :(
Can anyone help

6 comments
Comment actions Permalink

I've accidentally turned those things off before too.

I couldn't work out how to re-enable the import intention from the GUI, but if you want to edit a config file...

.IntelliJIDEA/config/options/other.xml

This file has an "IntentionManagerSettings" section from which you can delete the line that says:

]]>

(Close IDEA before editing the file.)

0
Comment actions Permalink

It looks like they may have changed it. other.xml is now in the idea.jar file and I don't see that entry anywhere. I'll keep looking, if you happen to see it or if anyone else knows please post.

0
Comment actions Permalink

Move the caret to the piece of code where you expect a light bulb, e.g. on the greyed out import statement. Then hit ALT+ENTER -> the light bulb popup appears. Now you can click on the grey light bulb to re-enable it.

0
Comment actions Permalink

"charles decroes" <charles@decroes.com> wrote in message
news:7266177.1038926505220.JavaMail.jrun@is.intellij.net...

Not sure what you call it but that light bulb use to pop up whenever I had

unused imports. It would allow me to select optimize imports. I accidently
turned it off for imports and I don't know how to turn it back on :(

Can anyone help


Go to an unused import.
Press alt-enter.
Click on the light bulb -> it should turn yellow again.

Carlos


0
Comment actions Permalink

ah-ha, thank you very much.

0
Comment actions Permalink

Thank you!

Now if only we could think of some ways to make the usability of intentions a bit less awkward (imho).

For example, I think I'd like the intention to popup if I simply moved the mouse pointer to the right area, rather than having to click first to move the caret into that area.

0

Please sign in to leave a comment.