Error: Cannot determine version for JDK

after upgrading to 684, my projects no longer compile. I get the error message

'Cannot determine version for JDK java version "1.4.1_01".Update JDK configuration'

can anybody please enlighten me what this means, and how to remedy it? This is a fully valid and complete JDK install, for which I have been compiling all the time.

thanks,
Christian

5 comments
Comment actions Permalink

go into project properties under paths and re-add jdk 1.4.1. This happens sometimes when you install the eap version with a jdk. Once you have installed one EAP build you should choose the no jre version and just unzip it into your intellij-home directory

0
Comment actions Permalink

thanks. Just for the record - I was using a "no jre" version. Wonder what is the cause for this..

0
Comment actions Permalink

i'm not sure what it is then. it only happened to me when i installed my first eap (which was a jre version). after that i have always used the non-jre version and it has not done that again. I guess it really doesn't matter what caused it as long as it doesn't happen continuously and we know how to fix it :)

0
Comment actions Permalink

The cause is most likely that the JDK version was not properly
saved/replaced in the configs.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Christian Sell" <christian.sell@netcologne.de> wrote in message
news:169390.1038908303088.JavaMail.jrun@is.intellij.net...

thanks. Just for the record - I was using a "no jre" version. Wonder what

is the cause for this..


0
Comment actions Permalink

that is kind of an easy answer :)
I guess we were trying to figure out the events that would have caused the configs to get overwritten or corupt in some manner.

0

Please sign in to leave a comment.