Ant and the <apply> task

I am using Ant with IntelliJ. In one part of my build script I use the ]]> tag to run a sqlj executable. The location of the executable is in my System path so this works fine from command line. When I run the build script through the IDE it fails with a NoClassDefFoundError on sqlj/tools/Sqlj. The aforementioned file exists in a zip file. I have added it to my System Classpath, project classpath, and the buildfile project classpath. No success. Please respond if you have any suggestions.

2 comments
Comment actions Permalink

Have you tried using the "newenvironment" attribute to include the zip file in the classpath for the task ?

Darshan

0
Comment actions Permalink

Thank you Darshan. I was able to solve this problem late last Friday and did not have a chance to update my orignal request for assistance.

The solution is to pass a command line argument as a tag rather than a since the classpath parameter has a space. Makes sense. More trial and error helped me out on this one. The following line notified the VM running through sqlj of the classpath variable: ]]>

For some reason only "classpath" worked, not "cp".

Hope this is some value to someone down the road.

0

Please sign in to leave a comment.