Stylus indentation broken by automatic formatting when using @extend and a pesudo-selector

When I take for example the following stylus definition and I do a "Reformat Code" or I just copy this snipped into another stylus file, it will remove necessary indenting:

form-info-text-line
    @extend .form-info-text
    
&:not(:last-child)
        border-bottom 1px solid $c-grey-fog


The following is how it looks after doing a "Reformat Code" or copying it into another stylus file:

form-info-text-line
    @extend .form-info-text
    
&:not(:last-child)
    border-bottom 1px solid $c-grey-fog


Is there any setting which would prevent that?
Could I disable auto-formatting for copy-paste actions just for stylus files?

Thank you,
André

1 comment
Comment actions Permalink

Logged as https://youtrack.jetbrains.com/issue/WEB-15094, please vote for it.
And no, it's not possible to set 'Reformat on paste' for a certan language only - this option affects all languages.

0

Please sign in to leave a comment.