speed

just for the record, I want to give my comments with regard to execution speed of the 3.0 release build (676). In my experience, there has been no significant improvement since this was last discussed during EAP. When opening a file for the first time after starting up the IDE, I still find myself waiting several seconds until the file has been parsed, and the IDE becomes responsive again. This happens even on rather small files.

Maybe this is a price we have to pay. However, I do not remember ever seeing these kinds of delays in version 2.6, nor in early EAP versions. Or is this just me?

still developing with pleasure,
Christian

21 comments
Comment actions Permalink

Other comments on the topic would be helpful.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Christian Sell" <christian.sell@netcologne.de> wrote in message
news:3497087.1037363395899.JavaMail.jrun@is.intellij.net...

just for the record, I want to give my comments with regard to execution

speed of the 3.0 release build (676). In my experience, there has been no
significant improvement since this was last discussed during EAP. When
opening a file for the first time after starting up the IDE, I still find
myself waiting several seconds until the file has been parsed, and the IDE
becomes responsive again. This happens even on rather small files.
>

Maybe this is a price we have to pay. However, I do not remember ever

seeing these kinds of delays in version 2.6, nor in early EAP versions. Or
is this just me?
>

still developing with pleasure,
Christian



0
Comment actions Permalink

I don't see a speed improvement either between build 629 and 3.0. The problem is that it's hard to pin down exactly what is slower, as the whole thing generally feels a bit more sluggish. Startup time for one thing is slower, I can try and run tests and give concrete examples of how long each bit of startup takes if you need that.

0
Comment actions Permalink

Hi Christian,

Please try 680. Do you see any improvements?

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Christian Sell" <christian.sell@netcologne.de> wrote in message
news:3497087.1037363395899.JavaMail.jrun@is.intellij.net...

just for the record, I want to give my comments with regard to execution

speed of the 3.0 release build (676). In my experience, there has been no
significant improvement since this was last discussed during EAP. When
opening a file for the first time after starting up the IDE, I still find
myself waiting several seconds until the file has been parsed, and the IDE
becomes responsive again. This happens even on rather small files.
>

Maybe this is a price we have to pay. However, I do not remember ever

seeing these kinds of delays in version 2.6, nor in early EAP versions. Or
is this just me?
>

still developing with pleasure,
Christian



0
Comment actions Permalink

680 starts up much faster that 676 (on OSX anyways), I haven't run into the 'huge long hang while saving caches' bug yet. Funny since I kept trying to trigger it to get a thread dump so I could file a bug ;)

0
Comment actions Permalink

Eugene Zhuravlev wrote:

Please try 680. Do you see any improvements?


For me the was startup time improvement: IDEA startup time went down to
~19 seconds in #680 from ~25 seconds on #676.

Jon

0
Comment actions Permalink

676 : Startup in 19 secs
680 : Startup in 11 secs

Cool!!!

0
Comment actions Permalink

I THINK I see an improvement, except in the one project which happens to have one monster file (6000 lines, www.thinlet.com) in its source path.

thanks,
Christian

0
Comment actions Permalink

Yep, it is slow comparing to 2.5. Maybe you could allow user to turn on/off
certain features, like build-in source control or XML parsing or... or
certain levels of parsing. For example, I do not need to check for correct
Javadocs every time. So, make the check-ups and parsing modular and
configurable.

Michael J.

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ar2rfq$se7$1@is.intellij.net...

Other comments on the topic would be helpful.

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"




0
Comment actions Permalink

What kind of operations are slow?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"Michael Jouravlev" <mikus@mail.ru> wrote in message
news:arc3qi$8mf$1@is.intellij.net...

Yep, it is slow comparing to 2.5. Maybe you could allow user to turn

on/off

certain features, like build-in source control or XML parsing or... or
certain levels of parsing. For example, I do not need to check for correct
Javadocs every time. So, make the check-ups and parsing modular and
configurable.

>

Michael J.

>

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ar2rfq$se7$1@is.intellij.net...

Other comments on the topic would be helpful.

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>
>
>


0
Comment actions Permalink

Try to add this in the idea.lax file after the memory settings:

-XX:NewRatio=2

This will minimize the full GC of idea and render the whole IDE MUCH MUCH snappier.

This setting is available on all platforms

0
Comment actions Permalink

On Wed, 20 Nov 2002 18:55:10 +0000, Robert S. Sfeir wrote:

Try to add this in the idea.lax file after the memory settings:
-XX:NewRatio=2


Where abouts is this file? I don't seem to have this anywhere on my linux
install?

Mark

0
Comment actions Permalink

On Linux look in idea.sh

0
Comment actions Permalink

-XX:NewRatio=2


I've been using this parameter for so long, that I had forgotten about it.
Thanks for the suggested it in the first place.


0
Comment actions Permalink

-XX:NewRatio=2
-Didea.jars.nocopy=true

Those options in bin/idea.lax seem to improve IDEA's speed a bit.

I'm running build 681 and I have after I've run/debugged my application a lot, IDEA seems to use a hell of a lot of memory (indicated by the bottom-right indicator bar).
It then hangs for a 4-7 seconds and then the ration on the indicator goes down a bit. It has the same effect when I click on the bottom-right "run garbage collector" option.

So I guess the application blocks when the garbage collector runs automatically. It does that on a very small project though, and memory consumption is a ratio out of 171 MB !!

It can be VERY annoying as I sometimes use mouse+keyboard actions that are not taken into account or that mess up my code because of the lag...

I have a Pentium III 1200MHz + 384MB SDRAM.

To fix this problem, I restart IDEA.

Thanks for a great product anyway, and
Thanks for listening !

Dan/


0
Comment actions Permalink

You might want to try tweaking the new ratio. Sometimes a setting of 3 is better, sometimes more... Depends on your environment and how you work I think. Also the suggestions about the new GCs in 1.4.1 seem really interesting, though I haven't tried them yet. If this is something that really annoys you, what I would do is turn on the GC debugger and start IDEA. On windows to see the command prompt you can control click the launcher, on UNIX well just launch ;), and then you will see how many small GCs you get, how fast they are, and how many full GCs you get and how long they take. As you tweak the GC settings and try again, you will see the difference between the two types of GC. If you want to get wild, I would gather the data, stick it in a spreadsheet and see how each change has affected the performance of the GC using IDEA...

Ok Now I'm getting out of hand... but not out of hand enough to not try it... :)

0
Comment actions Permalink

On my linux install, it's in...

<idea-install-dir>/bin/idea.lax

The "idea" launcher script file hunts for that properties file, there is no "idea.sh" (for me at least).

0
Comment actions Permalink

Hi Dan,

Try to add more RAM; >= 512 MB would be a good base.

Tom


On Thu, 21 Nov 2002 12:43:30 +0000 (UTC), dan
<jiveadmin@jetbrains.com> wrote:

-XX:NewRatio=2
-Didea.jars.nocopy=true

Those options in bin/idea.lax seem to improve IDEA's speed a bit.

I'm running build 681 and I have after I've run/debugged my application a lot, IDEA seems to use a hell of a lot of memory (indicated by the bottom-right indicator bar).
It then hangs for a 4-7 seconds and then the ration on the indicator goes down a bit. It has the same effect when I click on the bottom-right "run garbage collector" option.

So I guess the application blocks when the garbage collector runs automatically. It does that on a very small project though, and memory consumption is a ratio out of 171 MB !!

It can be VERY annoying as I sometimes use mouse+keyboard actions that are not taken into account or that mess up my code because of the lag...

I have a Pentium III 1200MHz + 384MB SDRAM.

To fix this problem, I restart IDEA.

Thanks for a great product anyway, and
Thanks for listening !

Dan/



0
Comment actions Permalink

The whole system is kinda slow. Apparently the main reason is lack of RAM
and Windows swaps a lot. My machine has 392MB of RAM, and I run several
tasks simultaneously. What I was thinking about is to disable loading of
certain modules to make application less memory-hungry and to decrease
swapping.

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ard0bh$etb$1@is.intellij.net...

What kind of operations are slow?

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>
>

"Michael Jouravlev" <mikus@mail.ru> wrote in message
news:arc3qi$8mf$1@is.intellij.net...

Yep, it is slow comparing to 2.5. Maybe you could allow user to turn

on/off

certain features, like build-in source control or XML parsing or... or
certain levels of parsing. For example, I do not need to check for

correct

Javadocs every time. So, make the check-ups and parsing modular and
configurable.

>

Michael J.

>

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ar2rfq$se7$1@is.intellij.net...

Other comments on the topic would be helpful.

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>
>
>

>
>


0
Comment actions Permalink

How much heap memory does it take (see the indicator at the right bottom
corner of IDEA frame)?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Michael Jouravlev" <mikus@mail.ru> wrote in message
news:arlpqk$r46$1@is.intellij.net...

The whole system is kinda slow. Apparently the main reason is lack of RAM
and Windows swaps a lot. My machine has 392MB of RAM, and I run several
tasks simultaneously. What I was thinking about is to disable loading of
certain modules to make application less memory-hungry and to decrease
swapping.

>

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ard0bh$etb$1@is.intellij.net...

What kind of operations are slow?

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>
>

"Michael Jouravlev" <mikus@mail.ru> wrote in message
news:arc3qi$8mf$1@is.intellij.net...

Yep, it is slow comparing to 2.5. Maybe you could allow user to turn

on/off

certain features, like build-in source control or XML parsing or... or
certain levels of parsing. For example, I do not need to check for

correct

Javadocs every time. So, make the check-ups and parsing modular and
configurable.

>

Michael J.

>

"Valentin Kipiatkov" <valentin@intellij.com> wrote in message
news:ar2rfq$se7$1@is.intellij.net...

Other comments on the topic would be helpful.

>

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

>
>
>

>
>

>
>


0
Comment actions Permalink

After a bit of tweaking, here is what my line looks like in idea.lax now:

lax.nl.java.option.additional=-Xms256m -Xmx396m -XX:NewRatio=3 -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC ....

I turned on both new Garbage collectors at the same time, upped the ram and increased the NewRatio. Things seems to run real fast, no hesitation and incremental GC happens almost all the time, it's pretty rare for me to get a full GC and major hang with these settings.

This doesn't mean it will work for everyone.

0
Comment actions Permalink

I additionally took out -Dsun.java2d.noddraw=true. If you have a Radion card you probably don't want to do this per http://developer.java.sun.com/developer/bugParade/bugs/4713003.html

Can anyone else think of a good reason to disable direct draw?

0

Please sign in to leave a comment.