IntelliJ 4.5 on Mac OSX 10.4.6: JDK incompatibility

I've got a G5 PowerMac runnign OSX 10.4.6. Not too long ago it auto upgraded the JDK to 1.5.0_06. Now when I try to run Intellij 4.5.4, I get a popup that says "The JDK version is 1.5.0_06 ]]> IDEA requires JDK 1.4.x on Mac".

Anyone know if I can install a separate 1.4 JDK on my Mac so that Intellij 4.5 will run, without trashing my JDK 1.5 installation? Any pointers to where to download the appropriate JDK, or installation tips that can live alongside with 1.5 would be great. I tried downloading 1.4 from the Apple site, but it is an upgrader, which doesnt help.

2 comments
Comment actions Permalink

I've got the same problem on my mac. If you check /System/Library/Frameworks/JavaVM.framework/Versions you can see you still have the 1.4 JRE, but I haven't figured out how to tell IntelliJ to use it.

0
Comment actions Permalink

Run Applications->Utilities->J2SE 5.0->Java Preferences

Under Java Application Runtime Settings you probably see J2SE 5.0 and J2SE 1.4.2. You need to drag one so 1.4.2 is listed first. Then Save.

Now restart IDEA 4.5.4 and you should be OK.

Of course if you now want to run IDEA 5.x or IDEA Demetra with JDK 1.5 (5.0) it gets more complicated.

Rick

0

Please sign in to leave a comment.