IDEA 5.1.1: Is the Resource Editor working?

Hi

I created two properties files lang.propertoes and lang_de.properties, so that in the project view a new Resource Bundle node is created.

However, whenever I open one of the properties files or pressing F4 in the project tree only an editor window is shown, but not the resource editor view, as shown in the help and in the i18n demo.

So - is the resource editor working in 5.1.1 (Build 4192) or do I miss something here ?

Kind regards

Thomas Gülden
Munich, Germany

4 comments

Strange - I installed the project on another machine. There, pressing F4 on the resource bundle node opens the Resource Bundle editor as expected.

Is there any known reason that the Resource Bundle editor does not open, perhaps any plugin (I can't compare the two installations as one is at home one is at work).

Kind regards

Thomas Gülden
Munich, Germany

0

IIRC if you upgraded from earlier versions of Idea and imported your settings
it might be that the extensions "properties" is mapped to text files.
Open the Settings -> IDE Settings -> File Types and assign "properties" to
the new file type "Properties Files".

Thomas Gülden wrote:

Strange - I installed the project on another machine. There, pressing F4 on the resource bundle node opens the Resource Bundle editor as expected.

Is there any known reason that the Resource Bundle editor does not open, perhaps any plugin (I can't compare the two installations as one is at home one is at work).

Kind regards

Thomas Gülden
Munich, Germany

0

Hi Stephen,

Thanks for the hint, but it seems not to be the reason that I can't get the Resource Bundle Editor to show up, as my properties files are already registered as a file type (I think it is already configured as a default after installation of IntelliJ).

I already did a fresh install before by removing the old installation directory and the config and system directory and reinstalling all the plugins I am using.

Any other idea ?

Kind regards

Thomas

0

I have the same problem Did anyone solve it?

0

Please sign in to leave a comment.