Filesystem synchronization issues (IDEA 5.1.1)

I'm using IDEA 5.1.1, and I keep getting synchronization issues. Lots of them...

Most of the time it happens when I run an SVN update command from IDEA. The symptoms are that the file changes from the filesystem are not detected in IDEA, even when I select "Synchronize" (tried the menu and the toolbar). The only way to make the changes show is by closing and reopening IDEA. The changes are there, and even if I run another "SVN update" it will tell me the file is up to date. However, if I run an "SVN compare with latest version", it will show differences.

Does anyone have any clue what I could do to stop this from happening?

[]s Gus


Hello Gustavo,

I'm using IDEA 5.1.1, and I keep getting synchronization issues. Lots
of them...

Should be fixed in 5.1.2:

Serge Baranov
JetBrains, Inc
"Develop with pleasure!"


I agree. It should be. But it's not...Same behavior as far fs synchonization is concerned.

Message was edited by:


I'm having a very similar issue with 5.1.2 and CVS. Something is out of whack, and even when I change a file in Idea it doesn't seem to pick it up. In fact, the highlighting of files that have changed disappears as soon as the file is saved. A commit doesn't do anything, unless I do a diff first (which does show the difference). File changes also don't get picked up during a build, I have to do a full rebuild all to get changes to take effect.


If you have ZoneAlarm installed, uninstall it or upgrade to 6.5.722.000 version, previous version has a bug causing such problem (didn't update file timestamps).

Quote from the ZoneAlarm 6.5.722.000 changelog:
- Fixed- LastWriteTime not being updated


I'm having a very similar problem in 5.1.2 (actually all of 5.0) Except I'm using CVS instead of SVN.


I've updated to the newest version of ZoneAlarm, and as Serge said this resolved my problem. These problems started after I installed ZoneAlarm a few weeks ago.



I'm not running ZoneAlarm... just Windows Firewall.


Please sign in to leave a comment.