How Do I Add Blade Support for 8.0.2 ?

I thought Laravel Blade was suppported out of the box. However all I can find is a 3rd party plugin.

How do I turn on Blade support ??

Many Thanks

6 comments
Comment actions Permalink

Edit - I added the plugin from https://plugins.jetbrains.com/plugin/7569?pr=phpStorm


Now my "Settings" Panel will no longer Open - I have restarted noth Storm as well as my whole Ubuntu Desktop.

0
Comment actions Permalink

Hi there,

I thought Laravel Blade was suppported out of the box.

It is -- it's bundled by default & working fine here. It even has it's own settings page -- have you looked for it?

Make sure that "Blade Support" plugin is enabled.

screen01.png

Please show a screenshot of whole editor window (including editor tab) when working with blade file (once you make your IDE working again).

It's possible that you have TextMate bundle active for blade files or something.

However all I can find is a 3rd party plugin.

It's NOT a 3rd party plugin. If you look more carefully you will notice "Vendor: JetBrains" text.

Now my "Settings" Panel will no longer Open - I have restarted noth Storm as well as my whole Ubuntu Desktop.

You will have to delete that recently installed plugin manually -- check the link below for Plugins folder location:

https://intellij-support.jetbrains.com/entries/23358108-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

0
Comment actions Permalink

Thank you for your rapid reply - I think part of the problem is that the blade plugin would not automoatically install through the "let Storm do it for you". This in turn might be becaue I installed Storm in /opt directory. This could be wrong, but I could not find any specific instructions where the best place was for Storm.

Ok - So I have found the plugins directory and there is no Blade plugin there - so nothing to manually unistall.

So unless you can think of an easy solutuon to why my settimngs panel will not open, I am thinling the only thing left for me to do is to reinstall the whole of Storm - but then that takes me back to the first question: where is the best place ???

Many thanks

0
Comment actions Permalink
Ok - So I have found the plugins directory and there is no Blade plugin there - so nothing to manually unistall

No clue then. Your IDE settings should be in ~/.WebIde80 -- just delete whole folder (back it up first if desired)

So unless you can think of an easy solutuon to why my settimngs panel will not open, I am thinling the only thing left for me to do is to reinstall the whole of Storm

That would be the best/safest solution.

but then that takes me back to the first question: where is the best place

Sorry, not a Linux user here.

But accordingly to https://www.jetbrains.com/phpstorm/download/ (Linux tab) it could be any location, even your home folder.

0
Comment actions Permalink

Many thanks !  Ok I have reinstalled Storm as well as installed the BLade plugin.

It all appears to be working except for 1 thing:

When I want a new file I expect top see a Blade template  with a blade icon. There are none. So I go to edit Live templates and I attempt to create one, however, it does not appear on the list and the template is not recognised as a Blade template with a Blade icon.

I have scaned over your user doc "Using Blade Templates"   

Many thanks !

0
Comment actions Permalink
as well as installed the BLade plugin.

What do you mean? Blade plugin is bundled by default (at least here on Windows) and I have not seen any forum threads / tickets about missing plugin.

In any case: please avoid installing any plugins by downloading plugin archives manually -- use built in functionality -- works the best (unless, of course, plugins is not available in official JB reppo).

So I go to edit Live templates and I attempt to create one, however, it does not appear on the list and the template is not recognised as a Blade template with a Blade icon.

Live Templates have no relation to creating new files. Live Templates is basically code snippets: some abbreviation once entered followed by special shortcut will be converted into some more complex code. They can only be used once file is created/opened for editing.

What you need is File Templates -- available at "Settings | Editor | File and Code Templates" or via context menu when accessing templates:

0

Please sign in to leave a comment.