Unable to Install due to Seg Fault: Fedora Core 5 (2.6.16-1.2096_FC5)

I upgraded my laptop to Fedora Core 5. Everything is working just fine except for the IntelliJ IDEA 4.5.4 install. I think this may actually be a ZeroG problem but I was wondering if anyone else has run across it and solved the problem.


$ sh idea-4.5.4.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

idea-4.5.4.bin: line 2182: 30525 Segmentation fault "/tmp/install.dir.30433/Linux/resource/jre/bin/java" -Djava.compiler=NONE -Xmx50331648 -Xms16777216 com.zerog.lax.LAX "/tmp/install.dir.30433/temp.lax" "/tmp/env.properties.30433"

3 comments
Comment actions Permalink

I was able to install IntelliJ IDEA 4.5.4 using the tarball from this location:
http://download.jetbrains.com/idea/idea-4.5.4.tar.gz]]>

While this doesn't "technically" solve the problem... it at least will allow people to see a working around to the installation problem. However, there is one important thing I'd like to point out for everyone: soft linking to the proper directory. Things weren't working after I untarred and linked to the JRE folder.

The solution is:
Link to the JDK root directory!

So... here's what I did:
tar -zxvf *.tar.gz
vim bin/idea.sh
cd idea-2553
ln -s /jdks/64/jdk1.5.0_06 jre
sh bin/idea.sh &


You'll note that I did not do this:
ln -s /jdks/64/jdk1.5.0_064/jre .

That will cause exceptions to be thrown out the wazoo (I never get to use that phrase).

The vim bin/idea.sh step was necessary not only to edit the basic JVM options (I increased the max memory to -Xmx1024m) but to also add the IDEA JVM option "-Didea.no.jdk.check=true". If you do not do that, IDEA will state that it is trying to run in the wrong environment.

If anyone finds a solution to the installation seg fault (or find out that it really is, in fact, ZeroG's problem), I'll mark this as "answered".

0
Comment actions Permalink

Two more things... this is stolen from thread http://intellij.net/forums/thread.jspa?forumID=22&messageID=3354726&threadID=101545 1. remove libbreakgen.so 2. soft link "amd64" in the Java bin directory (only if you're running AMD64, of course). rm /idea-2253/bin/libbreakgen.so cd /bin ln -s ../bin amd64 If you don't soft link amd64 in the Java bin directory, it will look for "/bin/amd64/java" and not be able to find it when you attempt to launch your application via "Play"/Shift+F10. And the libbreakgen.so is a standard removal (if you search the forums]]> you'll find a bunch of entries asking about it).

0
Comment actions Permalink

This is, indeed a ZeroG problem.

I posted a similar issue on LinuxQuestions.org in the following thread:
http://www.linuxquestions.org/questions/showthread.php?p=2256721#post2256721

Running the suggested solution in the post that I linked to there works just fine.
I'll copy that here for the lazy ones out there:
cp Install.bin Install.bak
cat Install.bak | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > Install.bin
rm Install.bak

0

Please sign in to leave a comment.