explicitly switch language to jsx harmony.

How does one explicitly switch to jsx harmony? I have react javacscript code which uses jsx but which ins't being prompted to switch automatically. Result - all of the jsx code shows up with red underlines.

Thanks

7 comments
Comment actions Permalink

Please try setting JavaScript Language Version to 'JSX Harmony' in Preferences/Languages&Frameworks/JavaScript

0
Comment actions Permalink

Add comment at top 

// language=JSX Harmony
0
Comment actions Permalink

what do you mean by "at top" to set //language-JSX Harmony.

 

Under Languages&Frameworks/JavaScript I see Reaxt JS a nd JSX in ESMA6Script. I set it to that, and still the issue is not resolved...

This was working fine and all of a sudden it happened....

Any idea as what to do?

P.S - My version is Unlimited Version 2017.3.5

0
Comment actions Permalink

>Under Languages&Frameworks/JavaScript I see Reaxt JS a nd JSX in ESMA6Script. I set it to that

Set it to what? Please attach a screenshot of  Languages&Frameworks | JavaScript preferences page.

Also, do you have any other projects open at the same time?

0
Comment actions Permalink

Hi, I have the same issue. Don't see a JSX Harmony in Preferences.
No other projects open at the same time.

Webstorm 2019.3.4

0
Comment actions Permalink

> Don't see a JSX Harmony in Preferences

it was renamed to React JSX

1

Please sign in to leave a comment.