debugging apps using jRockit

Hi folks,

have anyone been able to debug a webapp using jRockit R26 1.5.0?
It simply doesn't work for me. The JVM options looks fine.

thanks for any help,
_________________
/nodje

11 comments
Comment actions Permalink

Are there any exceptions in console or error messages?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"nodje" <no_reply@jetbrains.com> wrote in message news:3515415.1145877172752.JavaMail.itn@is.intellij.net...

Hi folks,

>

have anyone been able to debug a webapp using jRockit R26 1.5.0?
It simply doesn't work for me. The JVM options looks fine.

>

thanks for any help,
_________________
/nodje



0
Comment actions Permalink

nope, nothing. Everything seems normal, except that breakpoints are not taken into account.
It's exactly like if I had launched the webapp in Run mode.
And it actually starts a lot faster than with Sun JVM.
_________________
/nodje

0
Comment actions Permalink

What version of Weblogic are you using and how do you attach with the debugger: as a remote connection or a local debug session?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"nodje" <no_reply@jetbrains.com> wrote in message news:10868249.1145893084021.JavaMail.itn@is.intellij.net...

nope, nothing. Everything seems normal, except that breakpoints are not taken into account.
It's exactly like if I had launched the webapp in Run mode.
And it actually starts a lot faster than with Sun JVM.
_________________
/nodje



0
Comment actions Permalink

My problem doesn't seem to apply to only JRockit so I will start my own thread.

Message was edited by:
Michael Parmeley

0
Comment actions Permalink

Hi Eugene,

i'm actually not using Weblogic. I'm using Tomcat 5.5.16.
I debug using a local debug session. It works perfectly with Sun JVM, but behaves as if not being in debug mode with jRockit.
I didn't changed the JVM options as they seem in accordance with the jRockit documentation.
_________________
/nodje

0
Comment actions Permalink

Hello Michael,

Are you sure that your source code corresponds the deployed application?

It is ironic this was posted today as I was just getting ready to ask
a similiar thing.

I have problems debugging a remote weblogic instance using:

jrockit81sp5_142_08

on Weblogic 8.1 with service pack 5.

I have started Weblogic with the appropriate debug command line
options. IntelliJ can successfully connect to the debugging port
(using default 5005).

However, when I set a break point I get the error:

"Breakpoint is invalid: No executable code found at line <insert line
number here> in class <insert class name here>"

It does this in all classes I have tried putting break points in.

---
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

How do you set Tomcat to use JRockit?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"nodje" <no_reply@jetbrains.com> wrote in message news:14326242.1146033562409.JavaMail.itn@is.intellij.net...

Hi Eugene,

>

i'm actually not using Weblogic. I'm using Tomcat 5.5.16.
I debug using a local debug session. It works perfectly with Sun JVM, but behaves as if not being in debug mode with jRockit.
I didn't changed the JVM options as they seem in accordance with the jRockit documentation.
_________________
/nodje



0
Comment actions Permalink

Yeah the code was sync'd up, the problem was that I was being a dumb ass.

I didn't realize ANT's javac task, by default, doesn't generate code with symbolic debugging information. I added debug="true" to my javac ANT task and all was well.

The remote debugging is very cool! I didn't even know it was possible until I read chapter 6 of IntelliJ in Action.

Going to test out JSP debugging with the JSR45 plugin next. (have to read some BEA docs and see if weblogic 8.x is jsr45 compatiable first though...I would venture a guess and say it is, but I will check)

0
Comment actions Permalink

I simply change the configured target JDK in the Settings menu.

I'm not too clear about how IDEA use Tomcat, but according to the stacktrace it at least sets the JRE_HOME var to point to the selected JDK's home.

here's my IDEA debug console trace:

cmd /c D:\Java\apache-tomcat-5.5.16\bin\catalina.bat run
Using CATALINA_BASE: E:\Software\Idea50\system\tomcat_Alpha2WebApp_3ecf710c
Using CATALINA_HOME: D:\Java\apache-tomcat-5.5.16
Using CATALINA_TMPDIR: D:\Java\apache-tomcat-5.5.16\temp
Using JRE_HOME: D:\Java\j2sdk\jrockit-R26.0.0-jdk1.5.0_04
Connected to the target VM, address: '127.0.0.1:1181', transport: 'socket'
0 INFO : http11.Http11AprProtocol - Initializing Coyote HTTP/1.1 on http-8080
....................
23625 INFO : http11.Http11AprProtocol - Starting Coyote HTTP/1.1 on http-8080

0
Comment actions Permalink

Looks like debugger successfully connects to the VM and it seems that the problem is in that breakpoints are ignored.
First, where do you set breakpoints - in java code or JSP?
Second, does breakpoint icon change somehow (the checkmark appears)? If not then it means that the class with this name was not even
loaded into VM => check that sources you see in the editor really correspond to the classes Tomcat runs at the moment.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"nodje" <no_reply@jetbrains.com> wrote in message news:28751577.1146128537913.JavaMail.itn@is.intellij.net...
>I simply change the configured target JDK in the Settings menu.
>

I'm not too clear about how IDEA use Tomcat, but according to the stacktrace it at least sets the JRE_HOME var to point to the
selected JDK's home.

>

here's my IDEA debug console trace:

>

cmd /c D:\Java\apache-tomcat-5.5.16\bin\catalina.bat run
Using CATALINA_BASE: E:\Software\Idea50\system\tomcat_Alpha2WebApp_3ecf710c
Using CATALINA_HOME: D:\Java\apache-tomcat-5.5.16
Using CATALINA_TMPDIR: D:\Java\apache-tomcat-5.5.16\temp
Using JRE_HOME: D:\Java\j2sdk\jrockit-R26.0.0-jdk1.5.0_04
Connected to the target VM, address: '127.0.0.1:1181', transport: 'socket'
0 INFO : http11.Http11AprProtocol - Initializing Coyote HTTP/1.1 on http-8080
...................
23625 INFO : http11.Http11AprProtocol - Starting Coyote HTTP/1.1 on http-8080



0
Comment actions Permalink

well, after verifying the state of the breakpoints, I realized that some were actually working. And few minutes later that most of them were working....

In fact, there's only one breakpoint that doesn't work. The one I have chosen at first of course....

The faulty line is my SecurityFilter, in a method called for each and every action, very convenient place to test debugging.
Debugging with Sun's JVm works fine, as expected.
With jRockit, the debugger would stop on the first and the third line, but not on the middle one.

1. String pageReq = request.getServletPath();
2. Subject subject = ((Subject) (session.getAttribute(Auth.SUBJECT_SESSION_KEY)));
3. if (subject != null) {

I just can't figure out any reason for that not to being working.
I suppose I'll face some other identical inconsistencies in the future, but jRockit really rocks, it's some much faster, so I'll keep using it.

Sorry for that, next time I'll be more carreful. I really didn't expect the debugger to behave differently according tho the breakpoints.

cheers,
_______________
/nodje

0

Please sign in to leave a comment.