phpstorm and http server localhost only ?

Hi
if i have a project (compass / "nodejs"   files locates inside root =main =directory) . i launch an html file but phpstorm internal http server use localhost .
1) Is there a way to configure the  http phpstorm server for have ip ( internal network 192.168.x.x ) for test outside desktop ( mobile ) ?
2)nodejs support  express server ; is there a way to configure phpstorm to use this server with ip instead it internal server that use localhost ?
3) does the best way it the use of proxy for mapping beetween localhost /ip using the same port ?


regard's

6 comments
Comment actions Permalink

1) Here are instruction for connecting to PHPStorm internal web server from a different host:
- on a remote host, make sure to install JetBrains IDE Support extension into Chrome
- in extension options  (chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/options.html),  specify the IP and port of the target machine
- on a target computer, start PHPStorm, make sure that the port  specified in Settings | Build, Execution, Deployment | Debugger is the same as above and 'Can  accept external connections' is on. Open your project and run your  application
Note that it's highly recommended to change the default port (63324)  to some different one (8080, 8090) if you need to connect from external  host - it might not work otherwise

2) not sure what this question has to do with PHPStorm... You can specify a host/port server is listening to right in your server code. See http://stackoverflow.com/questions/9986220/bind-expressjs-to-a-specific-ip-address, for example

0
Comment actions Permalink

Hi
i  don't succeed to configure phpstorm to make work live edit on remote server http://192.168.x.x:8080
so i use server ip 192.168.x.x and port numer 8080 .
my phpstrom project is "in place"  inside the server directory
I try with static page in hope to then test with CMS php dynamic page !!!
here my 3 steps

CONFIGURE CHROME
"phpstorm chrome plugin" can be configure using server ip and portnumber (fiels exists )


CONFIGURE PHPSTORM  ( my steps)

a) configure built in port number ?? !! ( i use remote server not built in phpstrom build in server)
I go to s File ->setting->build -> Debugger
I see the panel with  " build in server 63342  can accept external connection "
From this panel:
0-i change port number to 8080
1- phpstorm  internal server can't be disable
2- phpstorm  external server (ip 192.168.x.x) can't be configure
3-phpstorm setting use one field location to configure both debug and internal server port number ????
4-the label name should be "debug port"  but not " built in server port "
5-this setting is for php or js  debug ...i only want to debug javascript to be able to use live edit !!

b)configure server php
I go to File-> settings -> Lang -> PHP-> Servers  when validate the remote server  , I try to validate the remote environment , i have got return informations in the panel but the button that is available is validate ( already done)  -Cancel -Help . If  Validation process is OK for phpstorm , it should close the windows  and show an explicit information like "OK" and toggle the button  of label "validate" to "close" . This is not not intuitive  ... whe have to close the windows using the cross bottom right icon !!
I think it is ok even no explicit error message

c) configure "javascript debug " instance
I go to run-> edit configuration
I create a "javascript debug " instance
set url and mapping

TEST PHPSTORM
I select the javascript  instance
I click on run   green icon
Chrome open 3 tabs
1 the page i want to debug and test ( see a)
2 file:///C:/Users/"myusername"/AppData/Local/Google/Chrome/
3 http://sxs/Application/chrome.exe

a) I test the page I want to "debug" ( to test live edit  ): I  can't see the structure of the page in DEBUG panel Elements ; live edit don't work
b) Phpstorm show me a pop up asking me "Waiting for connection from Jetbrain support extrension for Chrome
Please ensure you have installed the exension and IDE port configure port 63342 or see help "
c) the one click  livedit/javascript debug work for  localhost:63342. I don't succeed to configure :phpstrom chrome plugin , phpstrom to use liveedit ( Javascript debut ) on remote server 192.168.x.x:8080/directorie/page.html .


Can i have some Help ?
regard's

0
Comment actions Permalink

Sorry, I understood nothing from your email. Do you have your own web server running on  http://192.168.x.x:8080, and you like to debug your application on this server? Don't touch the extension and debugger settings then. All you need to do is setting the URL and Remote URL mappings in javascript Debug run configuration, and then use this configuration to debug your javascript. See http://confluence.jetbrains.com/display/WI/Starting+a+JavaScript+debug+session#StartingaJavaScriptdebugsession-Startingadebugsessionwhenusingadifferentwebserver

And, please, change the Chrome extension settings back to default

0
Comment actions Permalink

Hi
I only change the  chrome  ip:port  and it is ok ( it was very easy  to configure even I do it without understand why i do that .... ) .
thank's

0
Comment actions Permalink

I search for  many hours ( many  days)  how is implemented built in server and how GUI for built in server work ....and why we can't stop it .
This question was already post there is 2 years in the track web service .
It a shame to loose so many time for information that is available from users feedback !
a- Is it so difficult to find usefull information in phpstorm website  ?
b- Does forum is a waste of time ( for me and jetbrain team support )? and track is really where we user must go ?
c- Does the information about built in is cover in phpstorm documentation ? .
Easy tool , zero configuration ...all are nice but when we know a little more ( do it explicitly )

=== for summarize all that the implicit==
1- to configure http server  you need to go  to javascript setting
2- to launch live edit ( "dynamic html" ) , it is zero configuration ( nothing to configure) but phpstorm create for you a hidden "configuration file" for Javascript debug !!!


regard's

0
Comment actions Permalink
how GUI for built in server work ....and why we can't stop it .


it has no GUI (except for the port that can be configured in Settings/Build,Execution,Deployment/Debugger). This option is documented in https://www.jetbrains.com/webstorm/help/debugger.html.
And why do you need to turn it off?

Does forum is a waste of time ( for me and jetbrain team support )? and track is really where we user must go ?

It depends:) Forum is a place where you can ask questions and discuss features with other users (and get assistance from them). Jetbrains developers usually monitor it, but this is a low priority task for them, so you don't necessary get a responce.
If you need to get immediate assistance from official support (ask question or report a bug), create a support ticket at  https://intellij-support.jetbrains.com/anonymous_requests/new.
If you like to submit a feature request, file it to youtrack (https://youtrack.jetbrains.com/issues/WI). You can also use it to log a bug.
If you like to discuss certain things with other users - forum is your choice:)

to configure http server  you need to go  to javascript setting


it's not true. If you need to run/debug your HTML+JS application on certain web server, you need to specify its URL in javaScript Debug run configuration (isn't it unexpected?). You can also configure your server in Settings/Build,Execution,Deployment/Deployment - see http://confluence.jetbrains.com/display/PhpStorm/Deployments+in+PhpStorm. All new javaScript Debug run configurations will use this server by default

on launch live edit ( "dynamic html" ) , it is zero configuration ( nothing to configure) but phpstorm create for you a hidden "configuration file" for Javascript debug !!!



It's not a 'zero configuration' -  it's clearly stated in documentation that Live Edit only works while debugging and you need a run configuration to start it. But PHPStorm allows you to create this configuration automatically, by choosing Debug from your HTMl file right-click menu. It's a shame, of course :)

0

Please sign in to leave a comment.