Cursor gone after alt-tab

Answered

When I alt-tab to another application and back again, the cursor is gone! I have to click in the editor to be able to start typing again. This is SO annoying.

Is this a bug, or a feature?

I tried disabling the auto-save, but it didn´t help.

19 comments
Comment actions Permalink

What are your exact IDE/OS/JDK versions? (Help | About)

0
Comment actions Permalink

What are your exact IDE/OS/JDK versions? (Help | About)

IDE: 8.0.2
JRE: 1.6.0_65-b14-466.1-11M4716x86_64
JVM: Java Hotspot(tm) 64-bit server by Apple

(I wish I could copy/paste from the "about" box)

OS: OSX Yosemite 10.10.1 (14B25)

0
Comment actions Permalink

Seems to be https://youtrack.jetbrains.com/issue/IDEA-132221 . Vote/comment for the issue on tracker, describe your situation in details.

0
Comment actions Permalink
(I wish I could copy/paste from the "about" box)

You can -- just use the shortcut (Ctrl+C on Windows) -- no selection is required.

0
Comment actions Permalink

I think that issue is only intelliJ, and it is not exactly the same.

1
Comment actions Permalink

It's more like related issue: https://youtrack.jetbrains.com/issue/IDEA-122525 .

PhpStorm is based on the Intellij platform, so IDEA issues are applicable to the PhpStorm.

0
Comment actions Permalink

I am seeing this again in Webstorm on Ubuntu 18.04.

0
Comment actions Permalink

@Swansonmr12 what version do you use?

0
Comment actions Permalink

2018.1.4. My issue is slightly different now that I try again. The issue is when I close(using Esc) one of the utilities (like Ctrl+Shift+n file launcher, or Ctrl+Shift+f Find in Path). Cursor disappears completely.

0
Comment actions Permalink

@Swansonmr12 I can't reproduce that: http://recordit.co/ve8SEpOKi8

Please disable all 3rd party plugins (Settings | Plugins | Show: Custom), restart PhpStorm, and, if the issue persists, record a similar screencast - maybe I'll be able to spot what I was doing wrong. Thank you!

0
Comment actions Permalink

Just crossed my mind - it's probably this one: https://youtrack.jetbrains.com/issue/IDEA-191839

1
Comment actions Permalink

Ah yep, that's the one!

0
Comment actions Permalink

It happen to me. anybody can help?

IDE: 2018.2.4

JRE: 1.8.0_152-release-1248-b8 x86_64

JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

OS: macOS Mojave 10.14

1
Comment actions Permalink

This happens to me as well.

 

IDE: 2018.3.5

JRE: 1.8.0_201-b09

OS: Ubuntu 18.04

 

0
Comment actions Permalink
I have the same problem.(intellij IDE)
 
IDE : 2018.3.5(Latest)
JRE:1.8.0_172
OS: Windows 10 pro 1089 (OS Build 17763.348)
 
i use 27inch monitor(4k)

U2879VF

0
Comment actions Permalink

Same problem here. Does not depend on screen resolution or graphics drivers (at least, I am running Jetbrains IDEs on very different hardware and on every computer my cursor disappears after focus is lost.

I have Ubuntu with i3 as window manager.

1
Comment actions Permalink

This was fixed since IDE version 2018.1.5. If you're on a more recent version - please submit a new bug report at https://youtrack.jetbrains.com/newIssue providing IDE logs & describing the issue in details.

0
Comment actions Permalink

Fabian Feitsch, In bspwm issuesI  found a solution, but it seems that the wm isn't relevant for solution so maybe can help you too, check: https://github.com/baskerville/bspwm/issues/841#issuecomment-419708176 

0
Comment actions Permalink

Joaquin Garmendia This helped, thank you very, very much!!! As this seems to be common issue it would be nice to have it officially documented ...

1

Please sign in to leave a comment.