IDEA 5.1 debugs very slowly

I just upgraded to IDEA 5.1, and the debugger has become very slow. What I mean by this is that if step through a program (Step Into, Step Over, etc), it can take IDEA 1 to 5 seconds to finish each step operation. Moreover, if I attempt to expand a variable in the "Frame" tab, it takes around 5 seconds for IDEA to respond. During this time IDEA is not using any CPU. In fact, my CPU sits idle the entire time I'm waiting.
Is this a known issue? I should add that I'm not sure if this is due to my upgrade to 5.1, as I also upgraded to a new box at the same time and am now running a dual core AMD processor. Here is some system info:
JDK: Sun 1.5.0_06 (this is the JDK being used by my project)
Operating system: Linux (Ubuntu)
Kernel version: 2.6.15 (PREEMPT "k7" kernel from Ubuntu distribution).

Any ideas?

32 comments

Debugging against Weblogic is also very slow in 5.1 (build 4155). Not just
stepping in/through/out but it makes my whole app. run extremely slow. Much
slower than previous builds and much, much slower than just running Weblogic
from IDEA. I'm not sure what build this started in but no more than two
builds ago.

"Andy DePue" <no_mail@jetbrains.com> wrote in message
news:29720835.1139510366588.JavaMail.javamailuser@localhost...
>I just upgraded to IDEA 5.1, and the debugger has become very slow. What I
>mean by this is that if step through a program (Step Into, Step Over, etc),
>it can take IDEA 1 to 5 seconds to finish each step operation. Moreover,
>if I attempt to expand a variable in the "Frame" tab, it takes around 5
>seconds for IDEA to respond. During this time IDEA is not using any CPU.
>In fact, my CPU sits idle the entire time I'm waiting.

Is this a known issue? I should add that I'm not sure if this is due to
my upgrade to 5.1, as I also upgraded to a new box at the same time and am
now running a dual core AMD processor. Here is some system info:
JDK: Sun 1.5.0_06 (this is the JDK being used by my project)
Operating system: Linux (Ubuntu)
Kernel version: 2.6.15 (PREEMPT "k7" kernel from Ubuntu distribution).

>

Any ideas?



0

Okay, I just rolled back to build 4148 and it is MUCH faster.

"Brad L" <no@no.no> wrote in message news:dsg5hc$c2u$1@is.intellij.net...

Debugging against Weblogic is also very slow in 5.1 (build 4155). Not just
stepping in/through/out but it makes my whole app. run extremely slow.
Much slower than previous builds and much, much slower than just running
Weblogic from IDEA. I'm not sure what build this started in but no more
than two builds ago.

>

"Andy DePue" <no_mail@jetbrains.com> wrote in message
news:29720835.1139510366588.JavaMail.javamailuser@localhost...

>>I just upgraded to IDEA 5.1, and the debugger has become very slow. What
>>I mean by this is that if step through a program (Step Into, Step Over,
>>etc), it can take IDEA 1 to 5 seconds to finish each step operation.
>>Moreover, if I attempt to expand a variable in the "Frame" tab, it takes
>>around 5 seconds for IDEA to respond. During this time IDEA is not using
>>any CPU. In fact, my CPU sits idle the entire time I'm waiting.
>> Is this a known issue? I should add that I'm not sure if this is due to
>> my upgrade to 5.1, as I also upgraded to a new box at the same time and
>> am now running a dual core AMD processor. Here is some system info:
>> JDK: Sun 1.5.0_06 (this is the JDK being used by my project)
>> Operating system: Linux (Ubuntu)
>> Kernel version: 2.6.15 (PREEMPT "k7" kernel from Ubuntu distribution).
>>
>> Any ideas?
>>
>



0

Might be a linux issue. I run it on XP with JDK 1.5.0_04, and Tomcat and it works just as fast as it use to.

0

Might be a linux issue. I run it on XP with JDK
1.5.0_04, and Tomcat and it works just as fast as it
use to.



The fact that it sits there for a few seconds with no CPU or disk activity makes me wonder if it is a socket issue (since the debugger connects to the process via a socket) or some kind of sync issue with dual processor? Maybe the PREEMPT kernel aggrevates the issue? When IDEA is sitting there waiting, it is always when the "Frame" tab is displaying "Collecting data..." in its view area. It just seems to get hung on "Collecting data..." for a couple of seconds... the rest of the process seems to go about as fast as before. You would think upgrading to an Athlon 64 X2 4400+ would make things go faster. As it is now, the debugger is almost unusable for me.

0

Not sure it will help, but did you try to increase IDEA's JVM size?
(I also noticed that after upgrade debug became slow, but after increasing
memory to the same size as for 5.0 everything works fine. I use windows.)

"Andy DePue" <no_mail@jetbrains.com> wrote in message
news:8621381.1139520047138.JavaMail.javamailuser@localhost...

Might be a linux issue. I run it on XP with JDK
1.5.0_04, and Tomcat and it works just as fast as it
use to.

>
>

The fact that it sits there for a few seconds with no CPU or disk activity

makes me wonder if it is a socket issue (since the debugger connects to the
process via a socket) or some kind of sync issue with dual processor? Maybe
the PREEMPT kernel aggrevates the issue? When IDEA is sitting there
waiting, it is always when the "Frame" tab is displaying "Collecting
data..." in its view area. It just seems to get hung on "Collecting
data..." for a couple of seconds... the rest of the process seems to go
about as fast as before. You would think upgrading to an Athlon 64 X2 4400+
would make things go faster. As it is now, the debugger is almost unusable
for me.
>


0

I increased memory size, I tried to recompile Linux (with or without preemptible flag, etc), but got no effect. Still waiting for "Collecting Data...".

Also, thread information shows slowly. When a breakpoint is reached, first I wait for thread info, then - for stack info and after all for current frame info. Every operation longs for several seconds, so debugging is really very slow.

0

Yes, exactly the same as me. It sounds like we are both seeing the exact same issue. It's good to know that it's not the PREEMPT kernel. I might try fiddling around with JVM options to see if anything turns up.

0

So, I'm the only one seeing this on Windows? I can't debug my Weblogic
webapps it's so slow. My app just slows to a crawl. I'm using build 4155
with jdk1.5.0_06 and Weblogic 8.1.5. I thought build 4148 was better but I
was wrong.

"Marc Stock" <no_mail@jetbrains.com> wrote in message
news:22755873.1139517254620.JavaMail.javamailuser@localhost...

Might be a linux issue. I run it on XP with JDK 1.5.0_04, and Tomcat and
it works just as fast as it use to.



0

Hello Brad,

So, I'm the only one seeing this on Windows? I can't debug my Weblogic
webapps it's so slow. My app just slows to a crawl. I'm using build
4155 with jdk1.5.0_06 and Weblogic 8.1.5. I thought build 4148 was
better but I was wrong.


Just as a test, try to start IDEA with clean profile after renaming ~/.IntelliJIdea50
directory, then create the new project from scratch and see if you can reproduce
this issue.

Check that you are not using Method breakpoints.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Yours might be a slightly different issue... when the debugger is going slowly, is your CPU idle or maxed out? I think this is key for my issue, since my CPU and disk are both idle.

0

Thank you, thank you, thank you! I just disabled the one method breakpoint I
had enabled and that fixed it.

"Serge Baranov" <serge@jetbrains.com> wrote in message
news:837a32911d444558c7fc8f7d2b4b5a@127.0.0.1...

Hello Brad,

>
>> So, I'm the only one seeing this on Windows? I can't debug my Weblogic
>> webapps it's so slow. My app just slows to a crawl. I'm using build
>> 4155 with jdk1.5.0_06 and Weblogic 8.1.5. I thought build 4148 was
>> better but I was wrong.
>

Just as a test, try to start IDEA with clean profile after renaming
~/.IntelliJIdea50 directory, then create the new project from scratch and
see if you can reproduce this issue.

>

Check that you are not using Method breakpoints.

>

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>



0

Could you please send me your config files, all iml files, the ipr and iws files for your project?

0

I have the same problem on an AMD X2 running Fedora Core 5 Test 2. Increased the amount of memory and removed the .Intellijidea50 directory without effect. The funny thing is that there is no cpu usage while waiting for it to Collect data...

Any progress with this?

0

I also experienced this problem after upgrading my Gentoo Linux system to the 2.6.15 kernel. By downgrading to 2.6.12, I no longer experience the "Collecting data" pause when stepping through a program. The kernel configuration should be nearly the same, since I didn't change any 2.6.12 options when compiling the 2.6.15 version.

I originally thought it was due to my switching over to a nptl (native posix threading library) version of glibc, but that didn't have any effect.

Here's my configuration that doesn't have this problem:
Gentoo kernel: gentoo-sources-2.6.12-r10
JDK: Sun 1.5.0_06
Idea: 5.1 (build 4155)
Glibc: 2.3.5

Darryl

0

could u fix u'r problem?
I have the same problem and am trying to fix it.

thanks,

0

Serge's post reminded me of a case where this happened to me and my debugging became really slow (this was back on 4.5). I think I had a method breakpoint defined for a method that no longer existed. Clearing that breakpoint (actually I cleared them all just to be sure) fixed the problem.

This is a pretty old issued. It's too bad it hasn't been fixed yet.

0

That was my problem too although my method still existed. Is there a Jira
issue filed for that?

"Marc Stock" <no_mail@jetbrains.com> wrote in message
news:28336737.1140113066173.JavaMail.javamailuser@localhost...

Serge's post reminded me of a case where this happened to me and my
debugging became really slow (this was back on 4.5). I think I had a
method breakpoint defined for a method that no longer existed. Clearing
that breakpoint (actually I cleared them all just to be sure) fixed the
problem.

>

This is a pretty old issued. It's too bad it hasn't been fixed yet.



0

I believe the problem I'm seeing with slowdown is not the same as the method breakpoint issue. For one thing, I have no method breakpoints defined anywhere. For another, I get no CPU or disk activity while waiting. Also, others have had a slowdown exactly the same as mine on Linux, and one guy was able to eliminate the slowdown simply by using a different Linux kernel version. I'm beginning to think this has something to do with the debugger not interacting well with my particular Linux kernel (maybe a socket timing option, or some kind of native thread change?). It wouldn't be something as simple as the nagle algorithm getting enabled somehow for the debug socket connection, would it?

- Andy

0

I have the same problem and I also do not have any method breakpoints.

0

After upgrading 5.0 to 5.1, retaining the project settings, it is taking about 14 seconds to step or view the stack. Local debug, with just the 1 breakpoint set. Fedora Core 4 kernel 2.6.15-1.1831_FC4. IDEA_JDK=/opt/jdk1.5.0_05, project JVM 1.4.1_03. I have not yet updated the Windows PC or tried reverting back to 5.0 for linux.

0

Hello Tom,

TG> After upgrading 5.0 to 5.1, retaining the project settings, it is
TG> taking about 14 seconds to step or view the stack. Local debug, with
TG> just the 1 breakpoint set. Fedora Core 4 kernel 2.6.15-1.1831_FC4.
TG> IDEA_JDK=/opt/jdk1.5.0_05, project JVM 1.4.1_03. I have not yet
TG> updated the Windows PC or tried reverting back to 5.0 for linux.

As the testing has showed, the slowdown is caused by 2.6.15 Linux kernel,
and will go away if you downgrade to 2.6.14.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Hello Dmitry,

I rebooted to 2.6.14-1.1656_FC4 and the problem did indeed go away.

Thank you
Tom

0

Dmitry Jemerov (JetBrains) wrote:

As the testing has showed, the slowdown is caused by 2.6.15 Linux
kernel, and will go away if you downgrade to 2.6.14.


Do you any idea (even the faintest clue) as to what might be causing
this? Downgrading isn't a very good option for me :( Also, we'll have
more chance of getting this fixed if we have a bit more idea...

Regards,
Edwin

0

+1 on kernel 2.6.16rc4 on x86_64

0

Same problem here - very, very annoying...


Linux localhost 2.6.15-gentoo-r5 #1 PREEMPT Wed Feb 22 23:13:24 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3200+ AuthenticAMD GNU/Linux

0

Same problem here on 2.6.15, I would rather not downgrade.

0

Same here. I did the downgrade test and I got back the speed. It seems to be an 2.6.15 kernel issue.

0

I am running Idea 5.1 on XP and since upgrading my debugger runs at max CPU for a long time and when it finally returns control it is very very slow.

May I ask what is the recommended course of action to correct this?

Thanks!

0

What consequenses does running sysctl -w net.ipv4.tcp_abc=0 have on my linux system?

I see that debugging works as it should after running this command but what else does the command do since this is not a recommended workaround?


Regards,

BTJ

0

Please sign in to leave a comment.