unable to launch target VM

Hi,

I'm using #666, set target SDK to 1.4.1_01. Set up a webApp, with tomcat
4.0.4.
When I start to debug, a little window pops up. The title is "Process not
started".
The message is "Unable to launch target VM".

I checked the About from Help menu, the installed VM is Java HotSpot client
VM.

Could someone tell me what is wrong?

Best regards,
Keppel


8 comments
Comment actions Permalink

Keppel Yin wrote:

Hi,

>

I'm using #666, set target SDK to 1.4.1_01. Set up a webApp, with
tomcat
4.0.4.
When I start to debug, a little window pops up. The title is "Process
not started".
The message is "Unable to launch target VM".

>

I checked the About from Help menu, the installed VM is Java HotSpot
client VM.

>

Could someone tell me what is wrong?

>

When I was getting this problem it was down to a problem in my server.xml
file, strangly enough in my case tomcat would run as standalone and from the
IDEA standard run command, but debug would produce the error "Unable to
launch target VM". Once I'd fixed the server.xml & web.xml (my db pool jndi
config was wrong) IDEA just started working.. might be worth checking:

http://www.intellij.net/forums/thread.jsp?forum=4&thread=14192&tstart=0&tran
ge=15

--
Richard Osbaldeston
(http://www.osbald.co.uk)


0
Comment actions Permalink

Does the path to Catalina Home or Config directories have any spaces in it?

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Keppel Yin" <keppel.yin@microfocus.com> wrote in message
news:apn352$pqq$1@is.intellij.net...

Hi,

>

I'm using #666, set target SDK to 1.4.1_01. Set up a webApp, with tomcat
4.0.4.
When I start to debug, a little window pops up. The title is "Process not
started".
The message is "Unable to launch target VM".

>

I checked the About from Help menu, the installed VM is Java HotSpot

client

VM.

>

Could someone tell me what is wrong?

>

Best regards,
Keppel

>
>


0
Comment actions Permalink

Eugene Zhuravlev wrote:

Does the path to Catalina Home or Config directories have any spaces
in it?

>

I'll admit that in my desperation one of the things I also did was to
re-install
tomcat to a directory without any spaces in the path; in which case ignore
my
advice - go with Eugene's (sheesh)

Bit of a shame it goes for 'C:\Program Files\Apache Tomcat 4.0' as a
default.. mind

Richard
--
Richard Osbaldeston
(http://www.osbald.co.uk)


0
Comment actions Permalink

The bug with the spaces is fixed in 667.
Please also make sure the "Launch server before debugger attaches" is
checked.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Richard Osbaldeston" <rosbaldeston@no-spam.h-o-tmail.com> wrote in message
news:app2os$n8r$1@is.intellij.net...

Eugene Zhuravlev wrote:

>

Does the path to Catalina Home or Config directories have any spaces
in it?

>

>

I'll admit that in my desperation one of the things I also did was to
re-install
tomcat to a directory without any spaces in the path; in which case ignore
my
advice - go with Eugene's (sheesh)

>

Bit of a shame it goes for 'C:\Program Files\Apache Tomcat 4.0' as a
default.. mind

>

Richard
--
Richard Osbaldeston
(http://www.osbald.co.uk)

>
>


0
Comment actions Permalink

Is #667 going to available soon? As you suspected, My Tomcat is installed as
default, so it contains space.
Thanks for the advice, it lets me see the light in the complete darkness.

Keppel
"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:app2ua$nhc$1@is.intellij.net...

The bug with the spaces is fixed in 667.
Please also make sure the "Launch server before debugger attaches" is
checked.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>

"Richard Osbaldeston" <rosbaldeston@no-spam.h-o-tmail.com> wrote in

message

news:app2os$n8r$1@is.intellij.net...

Eugene Zhuravlev wrote:

>

Does the path to Catalina Home or Config directories have any spaces
in it?

>

>

I'll admit that in my desperation one of the things I also did was to
re-install
tomcat to a directory without any spaces in the path; in which case

ignore

my
advice - go with Eugene's (sheesh)

>

Bit of a shame it goes for 'C:\Program Files\Apache Tomcat 4.0' as a
default.. mind

>

Richard
--
Richard Osbaldeston
(http://www.osbald.co.uk)

>
>

>
>


0
Comment actions Permalink

Yes, the build will be available soon.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"Keppel Yin" <keppel.yin@microfocus.com> wrote in message
news:app642$skk$1@is.intellij.net...

Is #667 going to available soon? As you suspected, My Tomcat is installed

as

default, so it contains space.
Thanks for the advice, it lets me see the light in the complete darkness.

>

Keppel
"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:app2ua$nhc$1@is.intellij.net...

The bug with the spaces is fixed in 667.
Please also make sure the "Launch server before debugger attaches" is
checked.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>

"Richard Osbaldeston" <rosbaldeston@no-spam.h-o-tmail.com> wrote in

message

news:app2os$n8r$1@is.intellij.net...

Eugene Zhuravlev wrote:

>

Does the path to Catalina Home or Config directories have any spaces
in it?

>

>

I'll admit that in my desperation one of the things I also did was

to

re-install
tomcat to a directory without any spaces in the path; in which case

ignore

my
advice - go with Eugene's (sheesh)

>

Bit of a shame it goes for 'C:\Program Files\Apache Tomcat 4.0' as a
default.. mind

>

Richard
--
Richard Osbaldeston
(http://www.osbald.co.uk)

>
>

>
>

>
>


0
Comment actions Permalink

Eugene Zhuravlev wrote:

The bug with the spaces is fixed in 667.
Please also make sure the "Launch server before debugger attaches" is
checked.

>

Thanks for packing that fix in, will be nice to get away from that infernal
build number ;) the only other wrinkle I've noticed with the webapp
integration is that the user needs know to manually add servlet.jar to their
project classpath so IDEA can get the syntax highlighting correct on those
pesky implicit objects.. It's normally found in the tomcat 4.0.x Catalina
Home\commons\lib directory if anybody needs to find it.

Would make things really easy if it was added by default when the user
enables webapp support..

Richard
--
Richard Osbaldeston
(http://www.osbald.co.uk)


0
Comment actions Permalink

Typical obstacles for IDEA newbies setting up an IDEA project...

1.
+1 for implicit servlet.jar inclusion in a webapp project! The only issue is: which servlet.jar? 2.2? 2.3? 2.4? Thus, it would make sense to have a default library "Servlet 2.3/JSP 1.2" (in Project Properties/Paths/Libraries, pointing to IDEA's servlet.jar) that is automatically included in a webapp project!

2.
Why isn't "Launch server before debugger attaches" the default option? This is definitely the common case...

3.
Tomcat 4.0 comes with the root context deactivated. Hence, IDEA complains that there is no root context ("Run WebApp"/"Debug WebApp"). Isn't there a simple way to work around this so that IDEA can work with a fresh, unmodified Tomcat installation?

Juergen

0

Please sign in to leave a comment.