IntelliJ IDEA 4.5.2

After around 4 hours use of IntelliJ my machine grinds to a halt. Forcing a
garbage collect improves the speed a little, and restarting Intellij
improves this again, but invariably I have to restart my machine. After this
it screams along for about 4 hours, gradually slowing down.

I have local history turned off, is there anything else I can do

Hardware:

AMD XP 2400+
1G Ram

TIA

David McCallum



3 comments

See you got no responses - I generally don't either. I have the same issue as you - in fact, so bad that I'm very close to ditching IDEA after using it exclusively since 3.0 - I love the interface but the performance, overall, is terrible - and when I operate on the same project in Eclipse, it's better - not great, but noticeably better. Ultimately I'm finding that the inspections are the killers. The background inspection process just eats my machine for lunch when I switch back and forth between large files. I've been trying to turn them all off, well, all other than flagging things the compiler would flag - ie. pure syntax issues. (though there is at least one bug I know of that won't save a setting - "Probable bugs / Unused assignment / Report redundant initializers" - you can change this to whatever you want but when you restart IDEA it's back on - and it kills me because we generally initialize variables - unnecessary if you want the default value but it's a long-practiced style). These performance issues have been posted countless times on this forum but, IMHO anyway, the performance just continues to degrade with each new release. To my mind IDEA is just trying to do way too much for a client-side Java app. I'm also now finding that IDEA crashes a bit more regularly now. Anyway, what I can suggest is this: a) tweak your heap settings to see if you can minimize GC impact b) turn off as many of the source inspections as you can - nice idea but for me it simply kills performance on large source files in a large project c) look at the newer GC settings you can use if you're using a later jdk d) as a last, unfortunate move, evaluate Eclipse and see if it performs better for you. As much as I hate to do it, I don't think I've got much of a choice. If the editor in an IDE isn't fast and responsive, anything else built on top of it is pretty much academic - the tool's getting in my way now and I have way too much work to do to sit around waiting on that last character I typed to actually show up in my source. Best of luck.

0

Actually - sorry, you may find that most of the inspection stuff I was talking about isn't relevent pre-5.0. Actually didn't want to make this post - but apparently, when you use this new board system, if you preview your post then hit the browser back button a couple of times - you post. Realized that you weren't running 5.0 after that.
Scott

0

Try increasing your max memory setting in the idea.exe.vmoptions file that is in your ]]>\bin folder (e.g. C:\Program Files\JetBrains\IntelliJ IDEA 5.1.1\IntelliJ IDEA 5.1\bin). If you have 1G RAM, try setting it to "-Xmx512m"

Personally, I rarely see performance problems, but I am running IDEA on a machine with 2G of RAM, and I generally try to watch for any unnecessary junk in memory at any given moment. Generally, in my experience, 1Gig should be more than enough for IDEA to run smoothly. Running inspections - from the Analyze menu - does require a ton of memory, and will ctually choke with the default -Xmx setting if you have a large module/project. Also, you may want to check your machine's configuration, see what other apps are running. I have noticed that sometimes my laptop totally comes to a halt - when the network-scheduled anti-virus software kicks in.

0

Please sign in to leave a comment.