I'm new learning javascript , cant get WebStorm to open my code in any browser ?

I have a person web server ive downloaded and dont use. Could the problem be the way I have installed WebStorm. When I try to open a page thats in the web server root directory or even open a page in MyDocuments or any folder I get inthe browsers htttp box http://localhost:63342/alpha.htm/   where I tried to see the browser work, I put Alpha.htm in both the root directiry and the MyDocuments directorty. I get the same result. and the web page itself displays

404 Not Found

Index file doesn't exist.

There is actually an index file but why its wanting that i dont know, or cant find it.


Can I set up WebStorm to work properly withought using the local web server. Just any directory ? Im really not needing touse a web server at all . I love the way the editor works, I loaded some files into it and the mouse over features were great with the extra information they provide. This editor looks top of the top , the Alph of Editors. I just need it to work, display web pages ?

Need someones help please ?

3 comments
Comment actions Permalink

Hi there,

Your URL is invalid.

1) You have project name missing: it should be localhost:63342/PROJECT_NAME/alpha.htm at least.
2) You have trailing "/" -- this makes "alpha.htm" to be treated as folder and not a file (unless, actually, "alpha.htm" is the project name

Can I set up WebStorm to work properly withought using the local web server.

Yes -- just setup Deployment entry (Settings | Deployment) of correct type and mark it as Default for this project -- WebStorm will now use that server URL when opening files in browser.

0
Comment actions Permalink

Thank you Andriy for your response. I still am confused and have not got it working, to show the webpage. I have attached a pic of some settings where it is asking for a web server. I do not wish to connect WebSorm with my xampp server at at. But this pic shows WebStorm asking for a server. I'm pretty confused. I guess the project name is the one you create when you use File->New Project

then i get an input box to type in a title and my directory there is C:\Users\Angel 64bit\WebstormProjects\untitled1

At the moment i can just use the great editor but i then paste the code into Komodo Edit where I have many files open and it easily opens any code files into any browser ?????

Ive got programming and Math assignments coming due so i cant spend too much time trying to make this new editor work fully , the clocks really ticking..... :(



Attachment(s):
webstormsettngs.jpg
0
Comment actions Permalink

Hi again, i seem to have just got it working.
By opening a file that was in my xampp root directory into th
e editor. Then to my great surprise I
asked it to show the code in a web browser and it
worked .

this is the directory in the editor now   file:///C:/xampp/htdocs/index.htm


there is now no localhost which i did not understand ?

0

Please sign in to leave a comment.