Php debugger keeps losing focus?

I'm using ithe 138.1901 eap and am finding that when I debug php scripts the debugger keeps "losing focus." What I mean is that about four seconds after a breakpoint is triggered, the run and step buttons become greyed out and f8 doesn't work either -- I have to click on the topmost frame and then the buttons become available again (as well as the shortcuts).

"Losing focus" is the best way to describe this, I think.

Has anyone else had this issue? It's happened for the past couple of builds as well. I never noticed it in the stable (non-eap) version.

Regards,

Nate

4 comments
Comment actions Permalink

What's your OS? And do you have chance to provide a screencast?

0
Comment actions Permalink

I'm experiencing the same right now.

I've a break point, it was hit. Debugger panels are open at the bottom. The focus is on the "Frames" list, but debugger buttons are active colored.

After around 4 seconds suddenly the focus is lost on the debugger, the buttons turn gray (not clickable) and keyboard shortcuts also do not respond.

I did nothing in those 4 seconds, just watching the screen

I've to click inside the Frames to give it focus back then it works but after 4 seconds the same issue again (cat & mouse).

It does not happen in every debug session but the one I've open while typting this, does. And I remember having this issue already in the past with previous EAP and I think even with PhpStorm 7.

Using PhpStorm PS-138.2071
Build #PS-138.2071, built on September 5, 2014
JRE: 1.6.0_65-b14-462-11M4609 x86_64
JVM: Java HotSpot(TM) 64-Bit Server VM by Apple Inc.

Edit 1: right now this happens every time I break into a BP. I'm using the "Debug" button i.e. started an application on a remote server (CLI).

Edit 2: restarting PhpStorm EAP fixed it

Edit 3: after working a few hours, the debugger after intiating a ssh/remote cli debug session via the button started to loose focus again; immediately restarter PhpStorm, worked.

0
Comment actions Permalink

I'm having this same issue, I had noticed it a while ago,

I'm using windows 8, build date is Feb 25th 2014 (133.982)

I had thought my problem was because I upped my debug threads to 3 and that an ajax script was causing problems with the debugger thinking it had an incoming connection. I haven't been able to pin point the cause of why the debugger loses focus and the only way I can get focus back is to click on one of the list items in the debugger->frames window. It seems to be worse today as I will click on the item in the frames window, and immediately (less than 1 second) lose focus again several times in a row.

I haven't found a reliable way to reproduce the problem and my coworkers don't seem to have the same issue with an almost identical set up.

I would love to hear about a fix if you find one.

0
Comment actions Permalink

This is still happening in the latest EAP (8.0.2). I don't know if there's a bug ticket on YouTrack yet or not, but there should be..

0

Please sign in to leave a comment.