Make webstorm not ask password with git

Almost each time it push to repo on github webstorm asks to enter the passord. Is it possible to make it remember password and not ask each time?

Windows 7 x64 webstorm 9.

6 comments
Comment actions Permalink

What password storage policy is set in Settings/Appearance&Behavior/System Settings/Passwords?

0
Comment actions Permalink

Save on dict with master password protection

Master password Enabled

0
Comment actions Permalink

Hmm.. please try re-setting master password and then re-login (saving the password) - does it work?

0
Comment actions Permalink

Ok, I will try. Thanks.

0
Comment actions Permalink

That solution does not work for me. When I go to settings -> Appearance & Behavior -> System Settings -> Passwords I only have the option to or store in keepass (asks master password on each first connection to VCS) or to not save (even worse).

0
Comment actions Permalink

Same issue. I've set my github token to webstorm. It keeps ask my password for every commit and when i open github settings there is no token. So it being erased somehow.

0

Please sign in to leave a comment.