Where can I download older versions???

I need older version of IDEA since on my IBM machine all I can have is JDK140. Where can I download one of the older versions that required just the JDK14 and not 1.4.1?

thanks

Please sign in to leave a comment.