Compile project with one JDK; run with other JDK?

Hi,

Is it possile to configure a project to compile with, say, JDK 1.2.2, and
run the project with JDK 1.4.1?

tt


8 comments
Comment actions Permalink

No, the only way is to change the JDK before running.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK 1.2.2, and
run the project with JDK 1.4.1?

>

tt

>
>


0
Comment actions Permalink

Hi,

The reason I'm asking is that sometimes you want to use stuff like HotSwap
debugging on projects that have a target JDK <= 1.3.

I would be very surprised if I am the only one having this problem.

tt

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK 1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>


0
Comment actions Permalink

Well, hotswap is not supported by IDEA yet.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aojmak$s70$1@is.intellij.net...

Hi,

>

The reason I'm asking is that sometimes you want to use stuff like HotSwap
debugging on projects that have a target JDK <= 1.3.

>

I would be very surprised if I am the only one having this problem.

>

tt

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK 1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>

>
>


0
Comment actions Permalink

Sure would be nice if idea did add support for Hot Swapping. This would keep loyal idea users from going to other debuggers to use funtionality that has been out for several months now. :>)

0
Comment actions Permalink

That was just an example.

I you take the current release of IDEA, a scenario would be to compile with
IBM JDK 1.2.2 but debug with 1.4.1.

Debugging with 1.4.1 will be much faster, and more stable too.

tt

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:aok3sm$if0$1@is.intellij.net...

Well, hotswap is not supported by IDEA yet.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aojmak$s70$1@is.intellij.net...

Hi,

>

The reason I'm asking is that sometimes you want to use stuff like

HotSwap

debugging on projects that have a target JDK <= 1.3.

>

I would be very surprised if I am the only one having this problem.

>

tt

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK

1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>

>
>

>
>


0
Comment actions Permalink

+1

I'd like to have it, too.

changing the JRE setting all the time is not practicable

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aok6bn$mbp$1@is.intellij.net...

That was just an example.

>

I you take the current release of IDEA, a scenario would be to compile

with

IBM JDK 1.2.2 but debug with 1.4.1.

>

Debugging with 1.4.1 will be much faster, and more stable too.

>

tt

>

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:aok3sm$if0$1@is.intellij.net...

Well, hotswap is not supported by IDEA yet.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aojmak$s70$1@is.intellij.net...

Hi,

>

The reason I'm asking is that sometimes you want to use stuff like

HotSwap

debugging on projects that have a target JDK <= 1.3.

>

I would be very surprised if I am the only one having this problem.

>

tt

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK

1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>

>
>

>
>

>
>


0
Comment actions Permalink

Well, you are welcome to submit a feature request with the reasons to our
tracker (www.intellij.net/tracker)

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aok6bn$mbp$1@is.intellij.net...

That was just an example.

>

I you take the current release of IDEA, a scenario would be to compile

with

IBM JDK 1.2.2 but debug with 1.4.1.

>

Debugging with 1.4.1 will be much faster, and more stable too.

>

tt

>

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:aok3sm$if0$1@is.intellij.net...

Well, hotswap is not supported by IDEA yet.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aojmak$s70$1@is.intellij.net...

Hi,

>

The reason I'm asking is that sometimes you want to use stuff like

HotSwap

debugging on projects that have a target JDK <= 1.3.

>

I would be very surprised if I am the only one having this problem.

>

tt

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say, JDK

1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>

>
>

>
>

>
>


0
Comment actions Permalink

Hi,

"Allow different JDKs to be configured for compile/run/debug":
http://www.intellij.net/tracker/idea/viewSCR?publicId=5975

Regards,

tt

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:aolv0k$gju$1@is.intellij.net...

Well, you are welcome to submit a feature request with the reasons

to our

tracker (www.intellij.net/tracker)

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>
>

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aok6bn$mbp$1@is.intellij.net...

That was just an example.

>

I you take the current release of IDEA, a scenario would be to

compile

with

IBM JDK 1.2.2 but debug with 1.4.1.

>

Debugging with 1.4.1 will be much faster, and more stable too.

>

tt

>

"Eugene Zhuravlev" <jeka@intellij.com> wrote in message
news:aok3sm$if0$1@is.intellij.net...

Well, hotswap is not supported by IDEA yet.

>

--

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"Taras Tielkes" <taras@spam.info.nl> wrote in message
news:aojmak$s70$1@is.intellij.net...

Hi,

>

The reason I'm asking is that sometimes you want to use stuff

like

HotSwap

debugging on projects that have a target JDK <= 1.3.

>

I would be very surprised if I am the only one having this

problem.

>

tt

>

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

>

"pUnk" <punk@iunknown.com> wrote in message
news:aojl6a$q7e$1@is.intellij.net...

Hi,

>

Is it possile to configure a project to compile with, say,

JDK

1.2.2,

and

run the project with JDK 1.4.1?

>

tt

>

>
>

>
>

>
>

>
>


0

Please sign in to leave a comment.