How to change / turn off auto formatting in 9.0.1?

I have just downloaded 9.0.1, and have been getting very annoyed at the way it auto-formats.  The main issue I experience is that when I hit return, it may indent on the next line if it thinks the code structure should require it.  In most cases, I find that it does not.  Worse yet, if I hit Backspace to remove the indent, it completely removes the new line and now I am returned to the end of the previous line.  The ONLY way I can resolve this, is that one I hit return and it auto-indents me, then I have to use the cursor keys to move the cursor back 5 spaces so that I can be in the column alignment I wish the code to be in.

Previously versions did not do this, and I am quite frustrated that this new version does this as it is a constant annoyance.  Is there a way to set the auto-formating so that it functions like previous versions?  If not, then please advise how I can turn off auto-matting.

Thank you.

1 comment
Comment actions Permalink

Hi there,

Settings (Preferences on Mac) | Editor | General | Smart Keys -- it should contain all settings necessary -- have a look.

For Backspace -- "Backspace smart indent"
For Enter -- "Enter | Smart Indent" (if I understood you correctly)

0

Please sign in to leave a comment.