How to stop pop-up assist

I'm new to WebStorm as of about a month ago, just purchased and upgraded to 9 last week. Overall, great product, glad to have some familiar tools for Javascript development.

I would like to know how to stop ALL pop-up things in the editor from occurring, but still have analysis/inspection so I could access these if wanted. I went through all the settings multiple times and was able to turn off some things or increase the delays (why is there a forced upper bound of 1200ms or less for many of these?), but I cannot for the life of me get the little light bulb thing to stop popping up, in what seems to be 200ms, on *every line of source*. Really? Is that much live assistance ever desired? It is incredibly distracting and annoying, and most of the time is not fixing anything I need fixed. I cannot seem to get spelling corrections completely turned off.

So my short question is how to turn off that light bulb, and my broader comment is could you consider putting as many such pop-up intrusion settings in one place (and providing settings for all of them), with no cap or higher cap on delays? I imagine many coders are like me and prefer as little distraction as possible, and having to spend a good half day, as I did, tracking down every setting that is causing intrusive nagging "assistance" is a major annoyance. I suggest defaulting all of these to longer delays.

On a separate note, I saw another commenter's question about JS indentation no longer being honored, with the fix of turning of EditorConfig. While this solved the issue for me too, it would be nice to see patches for things like this coming out pretty quickly after a major release. The indentation problem was costing me a lot of time, as basically every new line of code you need to back up and correct it. Also I wonder what functionality is lost when turning off EditorConfig...

6 comments

Hi there,

So my short question is how to turn off that light bulb

There was an option just for that .. but it lived for few months only -- https://youtrack.jetbrains.com/issue/IDEA-94381#comment=27-565622

You still can turn it off, but you will need to edit one of the the config files manually (while IDE is closed, obviously):

Following line should be added to the $IDE_CONFIG_HOME/options/editor.xml then:

<option name="SHOW_INTENTION_BULB" value="false" />

Also: http://stackoverflow.com/a/20613210/783119

Also I wonder what functionality is lost when turning off EditorConfig...

Sure: their website is pretty clear on what EditorConfig is about.

https://www.jetbrains.com/webstorm/webhelp/configuring-code-style.html#d638721e320

it would be nice to see patches for things like this

What patches? What they supposed to fix?

If you are talking about editorconfig then there is nothing to fix -- it works as intended.

The only thing they could do (and I'm also unhappy about it) is to have some explanation text/notice next to that option (or some notification popup on first launch .. but then -- who reads popups on first launch...) so that people like you who are not familiar with EditorConfig would have a better chance on figuring out what is going on.

0

Where is $IDE_CONFIG_HOME/options/editor.xml on a Mac?

0

Not sure why my submitted reply didn't get saved... but I'm not seeing JetBrains or PHPStorm anywhere in my ~/Library/Preferences folder:


 

0

Would ls -la ~/Library/Preferences | grep PhpStorm return nothing?

If it would, please upload the IDE log after PhpStorm restart somewhere, we'll recover your config directory from there.

0

OK, it did return something:

Daves-iMac:~ dave$ ls -la ~/Library/Preferences | grep PhpStorm

drwxr-xr-x    8 dave  staff     272 Jun 25 08:25 PhpStorm2017.2

drwxr-xr-x   10 dave  staff     340 Aug  7 08:39 PhpStorm2018.1

drwxr-xr-x   15 dave  staff     510 Oct 22 09:21 PhpStorm2018.2

-rw-------    1 dave  staff     209 Oct  4 10:30 com.jetbrains.PhpStorm.plist

Why would Finder hide these?

0

Please sign in to leave a comment.