SFTP issues

When I try to connect with SFTP I get an error "Algorithm negotiation fail"; After the update to newest OpenSSH (OpenSSH_6.7p1 Debian-2, OpenSSL 1.0.1j 15 Oct 2014); I am running on a mac with Yosemite installed.

SSHD log show this:

Oct 28 14:22:42 elise sshd[4969]: debug1: Forked child 5096.
Oct 28 14:22:42 elise sshd[5096]: Set /proc/self/oom_score_adj to 0
Oct 28 14:22:42 elise sshd[5096]: debug1: rexec start in 5 out 5 newsock 5 pipe 7 sock 8
Oct 28 14:22:42 elise sshd[5096]: debug1: inetd sockets after dupping: 3, 3
Oct 28 14:22:42 elise sshd[5096]: Connection from xx.xx.xx.xx port 1369 on xx.xx.xx.xx port 22
Oct 28 14:22:42 elise sshd[5096]: debug1: Client protocol version 2.0; client software version JSCH-0.1.50
Oct 28 14:22:42 elise sshd[5096]: debug1: no match: JSCH-0.1.50
Oct 28 14:22:42 elise sshd[5096]: debug1: Enabling compatibility mode for protocol 2.0
Oct 28 14:22:42 elise sshd[5096]: debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-2
Oct 28 14:22:42 elise sshd[5096]: debug1: permanently_set_uid: 104/65534 [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: list_hostkey_types: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ssh-ed25519 [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: SSH2_MSG_KEXINIT sent [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: SSH2_MSG_KEXINIT received [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: kex: client->server aes128-ctr hmac-sha1 none [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: kex: server->client aes128-ctr hmac-sha1 none [preauth]
Oct 28 14:22:42 elise sshd[5096]: fatal: Unable to negotiate a key exchange method [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: do_cleanup [preauth]
Oct 28 14:22:42 elise sshd[5096]: debug1: monitor_read_log: child log fd closed
Oct 28 14:22:42 elise sshd[5096]: debug1: do_cleanup
Oct 28 14:22:42 elise sshd[5096]: debug1: Killing privsep child 5097

I would love to have some help with this as I cannot remotly work now;

11 comments
Comment actions Permalink

I am running: Java 8 Update 25 on Yosemite OSX;

I overwritten the policy files as stated in the article. Now I see a spinning loading icon next to my remote host and nothing happens.Seems like even authorisation isn't taking place.

SSHD serverlog:
Oct 28 14:50:16 elise sshd[4969]: debug1: Forked child 5388.
Oct 28 14:50:16 elise sshd[5388]: Set /proc/self/oom_score_adj to 0
Oct 28 14:50:16 elise sshd[5388]: debug1: rexec start in 5 out 5 newsock 5 pipe 7 sock 8
Oct 28 14:50:16 elise sshd[5388]: debug1: inetd sockets after dupping: 3, 3
Oct 28 14:50:16 elise sshd[5388]: Connection from xxx.xxx.xxx.xxx port 1332 on xxx.xxx.xxx.xxx port 22
Oct 28 14:50:16 elise sshd[5388]: debug1: Client protocol version 2.0; client software version JSCH-0.1.50
Oct 28 14:50:16 elise sshd[5388]: debug1: no match: JSCH-0.1.50
Oct 28 14:50:16 elise sshd[5388]: debug1: Enabling compatibility mode for protocol 2.0
Oct 28 14:50:16 elise sshd[5388]: debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-2
Oct 28 14:50:16 elise sshd[5388]: debug1: permanently_set_uid: 104/65534 [preauth]
Oct 28 14:50:16 elise sshd[5388]: debug1: list_hostkey_types: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ssh-ed25519 [preauth]
Oct 28 14:50:16 elise sshd[5388]: debug1: SSH2_MSG_KEXINIT sent [preauth]
Oct 28 14:50:18 elise sshd[5388]: Connection closed by xxx.xxx.xxx.xxx [preauth]
Oct 28 14:50:18 elise sshd[5388]: debug1: do_cleanup [preauth]
Oct 28 14:50:18 elise sshd[5388]: debug1: monitor_read_log: child log fd closed
Oct 28 14:50:18 elise sshd[5388]: debug1: do_cleanup
Oct 28 14:50:18 elise sshd[5388]: debug1: Killing privsep child 5389

0
Comment actions Permalink

Change the log level to deployment, reproduce the issue and provide the log (or corresponding part)
:

http://devnet.jetbrains.com/docs/DOC-1202
0
Comment actions Permalink

Problem seems to be related to:

Caused by: java.lang.SecurityException: Jurisdiction policy files are not signed by trusted signers!

0
Comment actions Permalink

Did it help?
I can see the similar stack trace in https://youtrack.jetbrains.com/issue/WI-8584 , see possible workaround in comments.

0
Comment actions Permalink

No, I am still having issues;

The new policy files seem not to be accepted by Java;

0
Comment actions Permalink

For now my workaround is to downgrade the SSHD deamon on my servers (not my choice, luckly this is a development server).

Hopefully this will be fixed in future release? any ETA on fix on this issue?

0
Comment actions Permalink

Any ETA can be provided by the responsible developer only. Vote/comment for the current investigation of the issue:
https://youtrack.jetbrains.com/issue/WI-25360

0
Comment actions Permalink

I am having a similair issue now.  My host provider appears to have changed something in their SSH settings, and I get this error.  The workaround suggested by Luba Melnikova on 10/28/2014 09:29 didn't fix it.

The only other useful bit of info I have is that I couldn't connect to the host (HostGator) with an older version of Putty - the connection was not being accepted.  Upgrading to the latest version fixed it.  But PhpStorm still can't connect.  I'm using version 7.1.5.

0
Comment actions Permalink

>  I'm using version 7.1.5.

 

Please try the same in one of the latest IDE versions (you can download one at our site or try an EAP build)

0

Please sign in to leave a comment.