JSP editing problems, etc.?

Is it just me, or is 5.x really buggy when it comes to editing and redeploying JSPs? I have been encountering all kinds of annoying problems. Foe example:

1. The editor often does not correctly highlight errors (it consistently fails to highlight undeclared taglibs, and sometimes it warning-highlights code (tags, attributes) that is ok.) The editor incorrectly identifies existing image files (specified in the form "images/myimage.gif") as "unknown" relative to the web root. It removes the highlighting only when you put a foreslash in font of the name: "/images/myimage.gif". However, for the page to render properly, HTML seems to work the other way around and will only recognize the first notation and won't find the image if specified in the way the editor suggests. Weird...

2. When I hot-redeploy JSPs more than a couple of times and then try to shutdown my server using the shutdown button in the Run window, IDEA freezes. It seems that the more times you redeploy within the same server life cycle, the deeper IDEA goes into some dead spin. I once went to lunch and when I got back I found it awake again, but it apparently took about 30 minutes or so for IDEA to come about... This is very consistent. What's up with that???

3. When I use the keyboard shortcut to comment code in a JSP, the idea creates an HTML comment instead of a JSP comment ("<%-- --%>"). Sometimes, it does create a JSP comment though... My old 4.x version didn't do this...

Has anyone else seen these problems? They all are very time-consuming. I wonder if anything is being done to fix them.

Thanks,
C

1 comment

Hi,

We are looking forward to JIRA items describing particular problems in
greater details in order to fix them.

Constantine Vasilyev wrote:

Is it just me, or is 5.x really buggy when it comes to editing and redeploying JSPs? I have been encountering all kinds of annoying problems. Foe example:
1. The editor often does not correctly highlight errors (it consistently fails to highlight undeclared taglibs, and sometimes it warning-highlights code

(tags, attributes) that is ok.) The editor incorrectly identifies
existing image files (specified in the form "images/myimage.gif") as
"unknown" relative to
the web root. It removes the highlighting only when you put a foreslash
in font of the name: "/images/myimage.gif". However, for the page to
render properly,
HTML seems to work the other way around and will only recognize the
first notation and won't find the image if specified in the way the
editor suggests.
It seems that some of the problems are caused by included jsps,
we are keen to see more details.

2. When I hot-redeploy JSPs more than a couple of times and then try to shutdown my server using the shutdown button in the Run window, IDEA freezes.

It seems that the more times you redeploy within the same server life
cycle, the deeper IDEA goes into some dead spin. I once went to lunch
and when I got
back I found it awake again, but it apparently took about 30 minutes or
so for IDEA to come about...
Please, attach thread dump to JIRA item, that will help to fix the problem.


3. When I use the keyboard shortcut to comment code in a JSP, the idea creates an HTML comment instead of a JSP comment ("<%-- --%>"). Sometimes, it does


create a JSP comment though... My old 4.x version didn't do this...
Your 4.5 version does not support 5 languages in one JSP file :), just
blindly inserts <%-- --%>, please, attach, simple jsp that cause the
problem.


Has anyone else seen these problems? They all are very time-consuming. I wonder if anything is being done to fix them.


Thank you for your participation.

--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.