show source in different modules

Hi,

I have several modules in my project. If I try to show source (Ctrl + click) to a class in different module but in the same project, I get a decompiled stub instead of the source. This also happens when stepping into between modules in the debugger.

Any ideas on how I can show source from one module to another?

Raj.

4 comments

Hello Raj,

You most probably added output path of the dependency module to the list
of libraries of dependent one. Instead, just tick a checkbox in Settings|Modules|Dependencies
list.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I have several modules in my project. If I try to show source (Ctrl +
click) to a class in different module but in the same project, I get a
decompiled stub instead of the source. This also happens when stepping
into between modules in the debugger.

Any ideas on how I can show source from one module to another?

Raj.



0

In the modules dialog I tick the modules required in the Dependencies tab. The IDE shows a decompiled stub upon show source.

I have also tried ticking or unticking the export boxes on the order/export tab, but it makes no difference.

I am using Idea 5.0.2 with a personal licence.

Raj.

0

Hello Raj,

Again, you seem have configured output path of one module as a library for
another one. That's where the problem lies.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

In the modules dialog I tick the modules required in the Dependencies
tab. The IDE shows a decompiled stub upon show source.

I have also tried ticking or unticking the export boxes on the
order/export tab, but it makes no difference.

I am using Idea 5.0.2 with a personal licence.

Raj.



0

Thanks for this. It turns out that I was telling all my modules to write their output into one universal classes/ location. I split the output up, placing it within each module instead, and this fixed the problem.

Raj.

0

Please sign in to leave a comment.