PHPStorm8 : How can I turn off namespace autocomprement?

Hello there,
I am a PHP developper in Japan.
I use PHPStorm8 and FuelPHP1.7.
When I am coding in FuelPHP, PHPStorm make namespace autocomprement.
like this:

public function action_check_token()
{
     \Fuel\Core\Input::post('token')       <---- I don't want '\Fuel\Core\'!!
}

Please help me!

2 comments
Comment actions Permalink

Hi there,

So .. what do you want instead? How should PHP/IDE know that "Input" is actually " \Fuel\Core\Input"?

The only way is to have "\Fuel\Core\Input" imported via "use" statement.

If that's what you want -- then just enable auto-import in namespace scope (use search box in Settings/Preferences and search for "import")

0
Comment actions Permalink

Hello Andriy,
Thank you for informing the resolution.
I'll turn on enable auto-import in namespace scope in preference.

0

Please sign in to leave a comment.