PhpStorm angularJS autocompletion does not work

Hi,

after installing the angularjs library via the setting I set up an index.php file which includes angular.js (not minimized). But no autocomplete is showing, and PhpStorm says "Attribute ng-XXX is not allowed here". The code works in my browser so angularjs is installed correctly.

My PhpStorm version is 8.0.1. What can I do?

Thanks for your help,

Ralph

4 comments
Comment actions Permalink

Hi there,

Do you have AngularJS plugin installed?

0
Comment actions Permalink

Hi,

yes, I think so. In Settings/Javascript/Libraries/Download/Community Stubs I downloaded and activated the angularjs library. Or is there any additional plugin I have to install?

Ralph

0
Comment actions Permalink

Thank you, that actually helped! Didn't find that in the blog or help.
In the Settings I now just searched for "plugin" and there ist was... :-)

Regards,

Ralph

0

Please sign in to leave a comment.