Problem with quotes in red

Hi,

I have a problem with 'back quotes'. When i use these ones in my PHP code with a MySQL string, PhpStorm marks them all red - it's really annoying. I have the latest PhpStorm 8.

What also is really weird, is that my PhpStorm on my workplace doesn't have this problem, while it is also the latest version. I exported those settings and imported them in my own PhpStorm at home. Didn't work :-(

See the attached screenshot. Someone know how to turn this annoying thing off?


Greetz,

Codyproxy



Attachment(s):
phpstorm_php_mysql.png
2 comments
Comment actions Permalink

Hi there,

What SQL Dialect  have you set up for your project / that file?

What menu do you see when you hit Alt+Enter when caret is located inside that SQL string?

0
Comment actions Permalink

Thank you,

My SQL Dialect was on 'Generic', i set the whole project on 'MySQL' and the red stuff dissappeared :-)

Still it's a bit weird, i can't remember i have ever set it on my work on 'MySQL', i'll check at monday.

PhpStorm is a great program, cannot do without it, but because it has so many options you sometimes cannot see the forest through the trees anymore (translated from dutch so i don't know if this phrase is english correct...)

0

Please sign in to leave a comment.