Newbie needs help setting up debugging Webstorm

I am an experienced programmer, but inexperienced in the world of web servers and web programming.

I am running Windows 7.


I would like to be able to have my files on my local drive and debug through WebStorm.
I was able to create a html5 boilerplate project, then replace the files created with my own html and js files.
When I try to debug through firefox (I have the JetBrains extension installed) I get a not well formed error on the json file that my javascript is trying to read in.

not well-formed    D:/Flash Code/3CISD/code/minigames/Fruit/FruitJS/resources/fruitsettings.json:1

The file is ok, I suspect I get the error because its a local file and its really a security issue.

I can run this code locally by running the node.js http-server.
For that to work I run the http-server at the folder where my index.html file is, then type in  localhost:8080 in the browser window.

How can I make WebStorm work with http-server?

I tried fiddling with Run/Debug Configurations but I am not familiar enough with all the buzzwords to make it work.

10 comments

Please see http://bit.ly/XGaiBG

Create a debug configuration of the type JavaScript Debug - Remote, set url to http://localhost:8080/index.html

0

Your link is broken. What is the correct link?


0

Do not click on the link -- instead select and copy-paste.

0

I've got it to run my app through firefox when I do Debug,
however, breakpoints don't work and no variables appear in the debugger window. The Variables window does show the word "Connected" with a blue icon next to it,
I have the jetbrains extension installed for firefox.

0

Please ensure that remote mappings are set (see run configuration). Or please try WebStorm 6 (http://blog.jetbrains.com/webide/2013/02/webstorm-6-public-preview-build/).

0

I installed Webstorm 6, no change.


Not exactly sure what you mean by "Please ensure that remote mappings are set"

The only settings I can find are in Run/Debug Configurations.
All that is there is URL to open

0

Hello everyone, I know that the thread is more than a year old but I have a similar problem with PHPStorm. I configured correctly my apache server and I can run my .php files. Though when I run or debug .html files they keep opening at http://localhost:63343 instead of http://127.0.0.1, like .php files. What am I doing wrong?

0

Hi Vladimir,

It does not seem to be working (PhpStorm v8.0.2 EAP build 139.14 .. but the same was during whole v8 EAP)

Deployment entry (of "In Place" type in my case) is configured and marked as default.

On browsers floating bar -- if I invoke it for .php file, it opens using URL from deployment entry -- all good here; but for .html files it uses localhost:63342

It used to be working in v7 .. but got broken in v8.

Other threads:
http://devnet.jetbrains.com/message/5521853#5521853

I strongly believe that you have a ticket about this .. but cannot find it right now.

I do not know why it behaves like that: maybe one of the plugins interfering ... but I have no idea what it could possible be

0

I guess I'm not the only one annoyed by it. Is there any workaround guys?

0

Please sign in to leave a comment.