8.0.1 VCS conflict resolution/merge dialog not showing on conflict

Hi guys,

i recently upgraded from PhpStorm 7.1 to 8.0.1 (Windows 7) and i'm wondering where the conflict resolution dialog during merged has gone.
In 7.1.3 PhpStorm displayed a conflict/merge dialog when the automatic merge routines of PhpStorm and Subversion failed during the merge.

In 8.0.1 the merge is running until the end and displays the commit dialog with not all files checked for commit (because of the conflicts).
When you close the dialog, go to changes and make a refresh all merged files are shown and as expected the conflicted files are red.
In this view the manual text merge conflict option is available - but this is not the behavior of PS 7

I already searched the community and the bug tracker but it seems that i am the only one experiencing this problem.
I tried to reinstall PhpStorm, installed it under two different operating systems (Windows XP, Ubuntu 14.04 LTS) but the problem is still there.
I also tried different Subversion versions (1.7 and 1.8) without success.

I am the only one experiencing this problem?
Maybe i missed some configuration options but i searched the whole configuration for "merge" and "conflict" and tried several combinations of the available settings without success.

Is there anyone out there who has a hint for me what i am doing wrong?

Thanks in advance!

Tobias

3 comments
Comment actions Permalink

Seems to be a problem of 8.0.1. I just installed the 8.0.2 EAP version and the conflict resolution dialog is there again.
Does anyone know if there any possibility to get this working in 8.0.1 until 8.0.2 is final?

0
Comment actions Permalink

You can safely use 8.0.2 EAPs, in this bug-fix-updates-phase they are basically the same that you'll get with release.

0
Comment actions Permalink

Thanks for the response!

0

Please sign in to leave a comment.