Project File's font changed from 7.1.3 to 8.0.1 - how to change it back?

It appears to me (maybe I am not remembering well, though) that the default font for the Project Files has changed for the default Darcula theme. I do not know what the original font was, nor how to change it back. Can someone please tell me? Thank you.

I am running PHPStorm on Windows 7.

10 comments
Comment actions Permalink

I double checked some old code screenshots I had and can confirm the font changed for me. It also changed in the menu bar, and tabs, and I am going to guess elsewhere, to this new, wider, font. Is there anywhere else it changed? (And again, how can I change it back?) I am not sure where to look for UI fonts in settings, although I found a lot of other fonts. (I found a command udner IDE Settings > Appearance to override default fonts, which is set to Segoe UI.)

0
Comment actions Permalink

Interestingly, I found that if I change the theme of the editor from "Darcula" to "Windows", the font appears to return to normal. But it is still set as Segoe UI (12pt) for both. So perhaps this is a different UI setting somewhere?
(Darcula now also appears to cause increased line spacing compared to the "Windows" theme.)

0
Comment actions Permalink

Hi there,

Settings | Appearance --> Override default fonts

P.S.
Settings screen has a handy search box (top left corner) -- try it (use "font" as a keyword) -- it works ok for such cases.

0
Comment actions Permalink

Hi Andriy,

I tried changing it via that method but I do not know what the original font was. It could be that PHPStorm is now rendering fonts differently, or maybe only Darcula is treating fonts differently than before as I cannot replicate the Window's theme font and line spacing around fonts - even my context menu has blown up, as the new font is larger and pushes text downward more. Overriding the font to the same font in both Darcula and the Windows theme yields different results.

I tried overriding with Segoe UI 9, 10, 11, and 12 pt but my original font was not replicated. I did not override the original font in 7.1.3, so I was using the default supplied there.

SS attached of my original font, top, and new, unwanted font, bottom.

(Edit: "Window's theme" refers to PHPStorm's Window's theme, not Window 7's theme in all of my posts above.)



Attachment(s):
font differences.png
0
Comment actions Permalink

Unfortunately I cannot really comment on Darcula as I'm not using it. But as far as I'm aware this was the same in v7 (font/row spacing).

All I can say is that I'm using Windows Theme as in all other themes font/row spacing is too big for my liking (I'm used to see compact Windows behaviour) -- on my screen the difference between Windows and Darcula is around 12-13 files in Project View (depends on theme).

I do not think that you can change font spacing via GUI. I believe it can only possible by editing the theme itself (for that you will have to edit some files in PhpStorm distribution .. which means editing again after installing newer version) unless there is some command line/hidden options for that.

Maybe one of the devs can give you a better solution/advice.

0
Comment actions Permalink

That is the same problem I am experiencing: things have become too large and I cannot see as many files as before. Everything is larger. Even the small difference depicted in the SS makes a large difference with a lot of text. (I cannot even have as many tabs open without getting the tab scroller!)

Do you know what font is default in the Windows theme? Maybe if I try overriding Darcula's theme with it, it might work. I tried Segoe UI only because I read it was MS Window's default font, but it doesn't seem like it is the same font used in the PHPStorm's Window's theme. (It almost looks like clear type is being applied to the font example on the bottom of my pic but not on the top. Just a guess, though.)

Do you know of a tutorial to edit theme's directly? Maybe I could investigate these things on my own.

(Thanks for your help regardless.)

1
Comment actions Permalink

I have exactly the same problem, after 2 years is not visible solution to the problem, it saddens...

 

1
Comment actions Permalink

@Blacknife11 is default font overridden in Settings/Preferences | Appearance & Behavior | Appearance?

0
Comment actions Permalink

no, this setting does not affect the project window:

phpStorm v 2017.3.3



0
Comment actions Permalink

Can't reproduce that: http://recordit.co/N55jCzG8c0
The setting affects the Project view, and also when it's unset the fonts look similar.

Is it possible that you provide us with the IDE log after PhpStorm restart (uploading it somewhere)?
https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files

0

Please sign in to leave a comment.