Scss tab size

After update to PhpStorm 8.0.2 in my *.scss files the tab size became 2 spaces. In Settings->Code Style->SCSS "Tab size" set as 4 (as I want).

In files of other types tab size works fine. Also I tried to change all tab sizes in "Code Style" to 4 and it doesn't affects to SCSS.

This is very uncomfortable. May be there is another place where I can set this option or it's a bug?

Attachment(s):
Settings2.png
4 comments
Comment actions Permalink

Do you have .editorconfig file anywhere in your project?

0
Comment actions Permalink

Yes I have.

Two files in different places inside of /vendor folder

; top-most EditorConfig file
root = true

; Unix-style newlines
[*]
end_of_line = LF

[*.php]
indent_style = space
indent_size = 4

[*.test]
indent_style = space
indent_size = 4

[*.rst]
indent_style = space
indent_size = 4

; top-most EditorConfig file
root = true

; Unix-style newlines
[*]
end_of_line = LF

[*.php]
indent_style = space
indent_size = 4
0
Comment actions Permalink

Do you have editor config plugin installed? if yes, does disabling it fix your tab size issue?
Please also check if the problem can be related to Code Style|General|Detect and use existing file indents for editing option: when enabled (default state), PHPStorm  automatically checks existing file indents and starts using them when  you copy and paste a fragment, press Enter, indent/unindent and so on

0
Comment actions Permalink

Yes the thing was in "Detect and use existing file indents for editing"
Thank you!

0

Please sign in to leave a comment.