Coping code from PHPStorm 8.0.1 all spaces are removed

PHPStorm 8.0.1Hi all,
When I moved to PHPStorm 8.0.1 from My PHPStorm 7.1.3 I found some strange thing:
I use KeepNote 0.7.8 as notebook and when I copy some code from PHPStorm 8.0.1 and paste it in page of KeepNote in this piece of code
all spaces are removed! I did not have this problem using PHPStorm 7 or some other program... Can it be some option for PHPStorm 8.0.1 for fix it in any way?

3 comments
Comment actions Permalink

Hi there,

Well .. the one thing I can think off -- is that it is because of new RichCopy feature (which does copy pretty formatted text (e.g. HTML/RTF) together with plain text).

  • Open Registry ("Help | Find Action" and search for it there)
  • Find editor.richcopy.strip.indents option and disable it
  • or just disable RichCopy functionality altogether via editor.richcopy.enable option
0
Comment actions Permalink

I did not find option editor.richcopy.strip.indents
[URL=http://www.radikal.ru][IMG]http://s015.radikal.ru/i331/1409/23/793f190aba6c.png[/IMG][/URL]

Also in Settings searching by "Rich" I found the only option
[URL=http://www.radikal.ru][IMG]http://s017.radikal.ru/i430/1409/ce/fed20c2eb309.png[/IMG][/URL]
But I do not see any option to disable richcopy.
Could you show which option have I to disable ?

0
Comment actions Permalink

You have missunderstood me.

I've told you to open Registry screen and search for those options there and not in "Find Action" or "Settings".

You supposed to use "Help | Find Action" to find and open the actual Registry screen.

screen01.png

screen02.png

0

Please sign in to leave a comment.