turning off jade template auto indent

I am editing some jade templates but am finding the auto indent feature to be incredibly annoying.  While great for javascript, I really don't like it for jade.  It indents after every line!  If I want to write a sequence of 'li' it indents and I have to manually move the beginning of the line.  However, if I feel like putting a line of white space inbetween, the next line tabs back to the indent.

It is probably something very simple, but can someone please tell me how to turn off auto-indent JUST for jade (or any individual code style really)?

Thanks

2 comments
Comment actions Permalink

Unfortunately "smart Indent' (Settings/Editor/Smart Keys/Enter) option is global - there is no way to suppress it for certain language/code construction (related ticket: http://youtrack.jetbrains.com/issue/WEB-6554).

0
Comment actions Permalink

Note: http://youtrack.jetbrains.com/issue/WEB-6162 is fixed in WebStorm 9, so smart indent in jade should now do a better job

0

Please sign in to leave a comment.