phpunit keyboard shortcut

Hi,

I a new to testing with phpunit, please be gentle with me :-)

Trying to create a new test file by using the keyboard shortcut CMD & SHIFT & T (on a Mac with the new phpstorm 8) causes ... nothing. There is no response at all. In the Navigate menu, the respective menu option is there, but grey. In the Preferences I deleted the short cut on "Thumbnails" (it was the same, but only worked on folders; it has a new one now).

What exactly do I have to do to make it work?

I follow this tutorial, which seems to assume that the short cut just works:
http://confluence.jetbrains.com/display/PhpStorm/PHPUnit+support+in+PhpStorm

BTW: I am working on a Symfony2 project, the test files should be created in:

src
   Blog
      CoreBundle
         Tests
            Controller

Thank you for your help!
Robert

2 comments
Comment actions Permalink

Hi there,

Yes -- shortcut just works / menu item is not disabled (Windows 7 here).

It only becomes disabled (for me, at least) if you trying to invoke it in wrong context (i.e. outside of the class/function).

Place cursor on class name in class declaration and try there.

0
Comment actions Permalink

Ahhh!!! That's how it works!

AWESOME!!!

Thank you very much for your quick response!!!

0

Please sign in to leave a comment.