How to change saved password for remote git repository


I have changed password of my git repository and now I am unable to pull / push from / to it from PhpStorm. I have previously saved old password in PhpStorm. Now I just get error "fatal: Authentication failed for..." but I don't see a way how to enter new credentials.

How can I clear saved password cache for git?



AFAIK Git doesn't use password, only key with passphase - maybe you need to regenerate this key? Or you have a Github account?


I don't use Github but I all the time work with private git (remote) repositories (for push / pull) where I have to enter username and password. This works fine in PhpStorm - I get modal window to enter credentials, but once remote password has changed I just got authetication error and pull / push failed. I was not provided an option to enter new credentials.

At the end I solved the problem to change master password in PhpStorm so all saved passwords were lost and again I was provided with modal window to enter new credentials. But downside of this approach is that also my other saved passwords for other projects were "lost" and I had to enter all of them again.


Yes, changing master password is a solution. You can also try to set PHPStorm do not remember passwords: . But in both cases the drawback is that you loose all stored passwords.
We have another request that should cover this use case: .


using windows 7 and intellij 2017.1. Tried all of that, still telling me that it is not able to authenticate. Also deleted the KeePas file, no luck. Please help.


In my opinion PHPStorm has very poor workflow when you have changed your Github password. You have to forget all  passwords to get it working, which is a royal pain in the ass if you've saved many FTP passwords.


Issue is still there, even though related youtrack tickets are marked as fixed.


Pavel, since the issue posted here was fixed, it's been broken once again here:
What version are you on?


You need to upgrade then, it's been fixed in 2017.3.


Still an issue with PyCharm 2017.3.3 on Ubuntu. The fix is to go into the Gnome Keyring and remove the entry in question.


Work around worked for me. I downloaded KeyPass and went to File > Settings > Appearance & Behavior > System Settings> Passwords, clicked on 'Do not save..", restarted IntelliJ and VCS asked for password again. 


Do not work all of these. PhpStorm 2018


The steps resolved issue for me in Windows

1. Go to Control Panel

2. Search for "Credentials"

3. Select Windows Credentials

4. Select github credentials from the list

5. Select edit and update your password then restart Intellij


For macOS users, passwords stored in KeyChain

  1. Go to KeyChain
  2. Look for "IntelliJ Platform Git HTTP"
  3. Edit and save changes
  4. Restart Intellij

Please sign in to leave a comment.