Getting the following error: "javac: invalid flag" when compiling jsp's

Hi,

I'm using IntelliJ 5.0 on Linux. When I try to access jsp's from the Tomcat 4 webserver, I get the following error:

javac: invalid flag: /home/bhaidri/.IntelliJIdea50/system/tomcat_Monthly
Usage: javac ]]>

The actual directory name has a space in it:

/home/bhaidri/.IntelliJIdea50/system/tomcat_Monthly Server_2dd60a6d

Therefore, this is causing a javac error. Any suggestions? I can't find anywhere in the IDE where I could have control over the naming of this directory, so that it could be named without spaces...

Thanks,
Baq Haidri

2 comments

Please check in Settings | IDE |FileTypes the associated extensions list for the "Java Source files" file type. I suspect you have
an empty extention in this list

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Baq Haidri" <no_mail@jetbrains.com> wrote in message news:26363261.1129841487609.JavaMail.itn@is.intellij.net...

Hi,

>

I'm using IntelliJ 5.0 on Linux. When I try to access jsp's from the Tomcat 4 webserver, I get the following error:

>

javac: invalid flag: /home/bhaidri/.IntelliJIdea50/system/tomcat_Monthly
Usage: javac <options> <source files>

>

The actual directory name has a space in it:

>

/home/bhaidri/.IntelliJIdea50/system/tomcat_Monthly Server_2dd60a6d

>

Therefore, this is causing a javac error. Any suggestions? I can't find anywhere in the IDE where I could have control over the
naming of this directory, so that it could be named without spaces...

>

Thanks,
Baq Haidri



0

Baq Haidri wrote:

The actual directory name has a space in it:

/home/bhaidri/.IntelliJIdea50/system/tomcat_Monthly Server_2dd60a6d


The thing between the 'tomcat_' and the hex-digits is the name of your
'run configuration' : "Monthly Server". Remove the space in the run
configuratio nname, and you'll be fine. (Run -> Edit configurations)
This is a bug.

Regards,
Edwin

0

Please sign in to leave a comment.