CVS Command Line on Mac (groveling for help)

Obviously, there's either something wrong with how the CVS pluggin works of the Mac or (more likely) something wrong with my CVS configuration.

Unfortunately, I can't tell. Nothin is coming out in the CVS console at all and the log doesn't have the contents of the CVS command line.

I've been at this for two days now and I really don't want to have to use the command line for all of my CVS needs.

Please, I'm begging you, if you have any thoughts, please share them.

Thank you,

Donad

7 comments
Comment actions Permalink

Try adding -Dcvs.print.output=true to the idea.exe.vmoptions file (or whatever
the mac uses: idea.sh?) and see if anything happens in the (idea) console.


0
Comment actions Permalink

Unfortunately I haven't been able to figure out where the JVM options go (not even to increase the available memory).

I don't think that there IS a console on the Mac (if there is, I haven't found it).

Still begging,

Donald

0
Comment actions Permalink

ok, a good idea is try to verify that everything is good from the command line first. Can you check out the source from the command line? which scheme are you using? pserver? ext? I always do encrypyed network protocols and I have found IDEA's internal ssh the easiest to configure.

0
Comment actions Permalink

I always do encrypyed network protocols and I have found IDEA's internal ssh the easiest to configure.


<shameless-plug>
Have you ever tried SmartCVS?
</shameless-plug>

Tom

0
Comment actions Permalink

Ok, I finally figured out.

The agent for Open SSH is greatly inferior to PuTTY on Windows.

I STILL never got any output in the CVS console window, even for successful commands. Why is that?

Donald

0
Comment actions Permalink

I spoke too soon.

Didn't get any output for a successful browse.

DID get output for a successful checkout.

0
Comment actions Permalink

Info.plist is where you set the options but I'm having this problem with CVS checkout complaining that it doesn't have enough memory to complete the option and I've set -Xmx to 1024m !!!

0

Please sign in to leave a comment.