'Confirm SSH Server key' keeps popping up when pushing to remote git repo

Hello,

A popup with the message 'Confirm SSH Server key' keeps popping up. The key is the same key every time. what do I nee to do to add this key to the known hosts database indefinitely?

13 comments
Comment actions Permalink

Please try connecting to your host via ssh in command line - does it help?


0
Comment actions Permalink

Nope, I connected through the terminal and when it still pops up when I push to the remote

0
Comment actions Permalink

What SSH do you use? cygwin?

Also, when re-connecting from terminal multiple times, does it ask for a key?

0
Comment actions Permalink

and one more question: what is the Settings | Version Control | Git | SSH executable option value?

0
Comment actions Permalink

That setting is the built-in, when I connect from the desktop I use PuTTY, but I used the built in one from phpstorm. when reconnecting it doesn't ask for a key

0
Comment actions Permalink

hmm... what OS do you work on?

0
Comment actions Permalink

windows 8, but the problem occurs on windows 7 as well

0
Comment actions Permalink

can you check if your host is added to ~/.ssh/known_host?

0
Comment actions Permalink

and where can I find that file?

0
Comment actions Permalink

that's a question:) Most probably in c:/users/<your name>/.ssh folder. But you can try searching for this file on your disk

0
Comment actions Permalink

I can't find the file, only thing I could find is the sshkey.tcl that belongs to git

0
Comment actions Permalink

do you have .ssh folder anywhere on your disk? If yes, where is it located and what files it contains? Also, please, can you attach your idea.log?

0
Comment actions Permalink

I cant find a .ssh folder



Attachment(s):
idea.log.zip
0

Please sign in to leave a comment.